Windows PC needing password to work with Infuse

Hi gang,

I’ve been using Infuse for 12 months now and love it, so this is only a small thing, but it does bother me a little and I was hoping there is a workaround.

I have an old Windows PC that I use for storage. This is accessed by Infuse on an Apple TV. I would rather run this PC without needing a username/password to get in, but when I do that Infuse can’t stream from it. Having a password resolves the issue, but it is a slight annoyance when the PC needs to be restarted as it is running without a monitor, keyboard or mouse.

Any ideas? Thanks!

I don’t quite understand what your problem is, normally when you set up a user (Infuse) with a name and password and you have authorized that user on a PC server you shouldn’t have to interact with it on either end once it’s running.

You talk about having to restart the PC causing problems, is that because the IP address is changing and causing it not to be found? If so maybe set it up with a network name instead of a number or set a dedicated IP address?

You’d need Infuse to have at least a Name to log in but many servers allow for “Guest” as a user without a password. It’s all in the settings.

What version of Windows are you running?

I’m pretty much an Apple ecosystem but it should be pretty straight forward on getting it running for you on windows.

If you attempt to connect to Windows via SMB without a password, Infuse will connect as a guest. This will likely limit the files/folders you have access to unless you specifically configure guests to access your files - which may not be the best idea.

Adding a username and password to Infuse will allow the app to connect as a registered user, which will provide access to your files.

If you want to avoid the sign in prompts when restarting the PC, you may try the steps in the link below to enable auto-login.

Thanks for the reply! Infuse does run fine and without any interference - totally perfect. I would just rather the PC not require a login page (there is nothing sensitive on it at all) to keep background tasks going. The PC handles a couple of things in the house and needs to be logged in when on - due to Infuse requiring a login if it ever does a power cycle for whatever reason it now just sits at the login screen.

I’ll give the ‘Guest’ thing a crack, thanks!

You’re a wizard! Thanks so much.

For anyone Googling this in the future, I used this guide below to skip login:

I did have to create DefaultUser, DefaultPass and AutoAdminLogon in the regedit as they were not there by default. Nothing exploded, my house is still standing.

1 Like