[Windows 10] Intermittent SMB connection errors

Hi. I’m using the latest version of Infuse 5; I regularly connect via SMB to a Windows 10 machine with both my iPhone 7 & iPad Air 2 (iOS 12.1.3). Occasionally one device or the other will show an error when attempting to connect to a saved Windows SMB share. Sometimes rebooting the device solves it, but not always; sometimes rebooting the Windows machine seems to solve it, but not always.

As I say, it’s intermittent, and often one device will be able to get in but the other won’t. I’ve assumed (correct me if I’m wrong) that there may be a connection limit or lock, so I never try to connect with the iPhone if the iPad is already connected, or vice versa; thus I don’t think that’s the problem.

Any suggestions?

Have you tried using other levels of SMB? Some have found that instead of using “Auto” they have better results using either level 2 or “Legacy”.

I’ve tried SMB 2, SMB 3, and Legacy… at the moment, all 3 work from my iPad Air 2 but none work with my iPhone 7.
Thanks for the suggestion, though.

Are you running any AV/firewall/security software on your windows box? If so try disabling it temporarily to see if it fixes the issue. HIPS software can mess around with connections from other machines.

It’s suddenly working on both devices. Seems to go on and off randomly. I’ll try your suggestion next time I have this issue. Thanks!