Will Seasonpass jailbreak Appletv2 4.3 8F455

Hi there,

I just purchased a new appletvthe software version is 4.3 8F455

I have tried to jailbreak it with greenpois0n, snowbreeze and season pass and none of them work.

  • To begin with greenposion said that the jail brake was successful, i left it plugged in for 5 mins after completion, when i connected to my tv there was no greenpoison menu, ive tried this several times and now it keeps saying jailbrake failed.
  • I cant get snowbreeze to work at all.
  • Season pass runs and creates the custom firmware, but when it comes to the itunes bit my apple tv is not showing up. I used ireb to put the appletv2 into pawned dfu mode and it is then picked up in my itunes, itunes starts to restore and i get error 1601, error 1600 ive tried it so many times and it wont work. I only have the appltetv2 plugged into the usb. and I have restarted the computer (windows vista) loads of times to no avail. My hosts is pointing to cydia because i have a jailbroken iphone. I have read that i need to point the hosts back to apple servers and this should stop 1600 1601 errors, i will try this tonight.

Is there anything else that i can do???

sorry for the long question but its been driving me mad not being able to jailbreak, the iphone was so easy compared to this lol

Just letting the firecore team know that I too am looking vey much forward to their response to this issue - none of previous j.b. methods appear to work after 8f455. Dang.

+1 need this feature. 


Apple stopped signing old firmwares, i didn’t get SHSH blob. so really need this feature to be able to buy/use aTV. 

Seas0nPass needs an update to work with the new 8F455 firmware.

Stay tuned.

Eureka - got it going - here is how: I followed this guide from July 28 by learnlinux: http://moblinlinux.cyacomputerblog.com/2011/07/28/watch-jailbreak-apple-tv-2g-4-2-2-4-3-untethered-seas0npass-macwindows/

You’ll notice that he follows the standard seasonpass procedure - but this time on Win7 whereas I had used Lion in previous tries. Suspect that to be the main differentiator. Simply followed the SP procedure and shift-restored using the SP generated IPSW file (…305 variant, w.o. Vimeo etc). I then plugged in the USB AND the power cable (adding the power cable was the only way I could force the atv2 into DFU). Then into itunes, shift-restore and choose the …305.ipsw file, then itunes 10.4 Windows version does the rest. It spent about 10 minutes, then reported the 1602 error. I was about to follow learnlinux procedure on how to get over that error, but decided to go and hook up the atv2 to my TV just in case - and presto - it had in fact been jb’ed despite the 1602 error report - weird, but great. Then applied atv flash, works like a gem.

Thank you for the update. I will try this sometime this week, and report back ASAP.

Any ideas when this will be?



You said you got it going…But what OS version did you have on the Apple TV2 prior to trying this?  You said you had success with  the 305 version, but did you hve 455 version on, and went back to 305?


I updated mine to 455 version by mistake and currently do not have my aTV 2 jailbroken and want to get it back to being jailbroken.

I am having a right nightmare

first of all my appletv2 wont go into dfu mode and be recognised in itunes i have to use ireb to force it into a pawned dfu mode…why the hell wont it recognise it normally???

once in pawned dfu mode itunes recognises the appletv2 and i select the firmware that seasonpass created, it starts to restore the appletv at this point the light on the front is flashing really fast so its in dfu mode, during the restore i here the ding dong noise that it makes when you attach a usb, the light then slows right down and flashes slowly??? is this normal?? I then get a mixture of errors either 1600 1601 or 1602…i thought using ireb to force the dfu mode stops these kind of errors from occuring…obviously not.

I have now tried to do a normal restore using offical apple firmware and i get the same errors. so if i cant even do a normal restore then it aint gonna work for a jailbreak…whats going on?

Are the problems i am having due to i me having updated to the latest firmware 4.3 version 8F455, james you said early that seasonpass needs an update for it to work on this firmware

I just dont know what to do and feel like sending the apple tv back to argos and getting my money back :@(


Johnnyp, you are havig the same type issues I had yesterday.  You are getting those errors becaause yes, you updated to the latest update from Apple.  I would just put the normal current Apple TV 2 OS on the device and wait till seas0npass or another jailbreak tool is updated for the new OS update.  That is what I am doing.

I just bought my first ATV and yesterday during set up I was asked to update to 8F455 and innocently did it. Now I found that version can’t be yet jailbreaked.

I wonder if there is anyway to restore an older firmware in order to jailbreak.

If not, how long it usually takes to have the new seasonpass working for the new updates? Should it take days, weeks or months?

I’ve read somebody was able to use seasonpass on this last build? Is there any risk on trying to do it?



Frankly I did not make a note of this - but I did standard-update via wlan just 2 days in advance of jb’ing, so I assume it was 455 - it had the vimeo feature in it. I downloaded the official (latest) version of season pass today and used it to generate the ipws restore file - which it named 305 (as James’ note implied hence 455 is not supported by seasonpass yet). Notice once again that I had to use the power cable to enter into DFU using the 7sec double key action. Once the 305 was ready, the itunes shift-restore action allowed me to restore the 305 on top of 455 (again, I believe it was the 455).


It seems after this current update you cannot downgrade unless you have your ssh blobs saved and I don’t as it was a brand new appletv2

Guess I’ll have to wait until there’s a jailbreak fir thus new firmware

For what it may be worth, try getting into DFU by having the power cable in - my atv2 was completely ignorant of any attempt to DFU until I did that. From Season Pass on Win7 I managed to get into DFU mode. As per my other post, 305 then was restored on top of 455, so overwriting should not be an issue - in generel I wouldn’t expect any ROM to exclude the replacement with any other.

I just did a jailbreak, but when iTunes was selecting the ISPW file I noticed that the file name was called 4.3 but when I checked the ATV2 it was running on 4.2.2


How long until the update is up?

Hi everyone,

Success at last…i can confrm that i have just succesfully restored from 4.3 8F455 back to 4.2.2 (2203).

I left my power supply plugged in, forced the appletv2 into pawned mode using ireb and used itunes to restore the firmware from seasonpass.

Initially itunes gave me error 1600 so i loaded up ireb again forced the appletv2 back into dfu mode and restored once again…this time it went through all of the stages saying it was restoring the firmware…it took ages…then it said error 1602…I unplugged from computer and hooked upto tv and hey presto it was jailbroken…itunes is sneaky and saying the restore was unsucessful when it was…so i woud recommend that if your itunes goes through the whole firmware update and still gives u an error…try it in your tv before you start another restore.

it took me 3 days and the little appletv2 was very lucky not to be thrown out the window…but know its done im happy…keep trying guys



I also confirm that last night, around 8PM Central time I still was able to downgrade from 8F455 using itunes restore and then jailbreeak applying seas0npass. My ATV2 (bought 2 weeks ago) wasn’t able to get into DFU but it did as soon as I plugged the power cable too. Everything went smooth except for itunes reporting error 1602, but when I connected to the TV everything was working ok.


Already installed NitoTV and XBMC and everything works as it should.



A mate of mine has just purchased an Apple TV 2 direct from Apple, and it came with 4.3 8F455  :frowning:

Is there any update on when a jailbreak will be available for this firmware or can he downgrade to a firmware that can be jailbroken??

Thanks in advance



455 - not yet. Meanwhile, try following the previous posts to downgrade to 305 - it is doable.


I’d suggest doing the downgrade to 305 as well. Very quick, easy, and great until seas0nPass is updated. I am just glad to be using the atv2 again to stream video off of the 2 terabyte HD that is attached to my original atv in another room.