Why Firefox 2.0 in ATVFlash 4.03?

Just wondering the reason for an old version like Firefox 2.0 in a current version of ATV Flash 4.03. Why not use the latest version of firefox?

Just curious… Wondering if I should update it, or if there is a reason not to update it.

Firefox 2.x is a bit more lightweight and seems to run better on the AppleTV.

When I try to run the 2.x version of Firefox that ATVFlash insists on installing I'm getting a message saying that I am running an old version and need to upgrade.

In my experience firefox 3 works pretty well and is fully compatible with all the latest web technologies.

I haven't noticed that great lack in performace compared with v2, even in flash streaming (well, of course HD is too heavy for this processor).

If you wish to try it just drag and drop the application from the dmg (on your mac) to the application folder (on ATV).


More details for installing Firefox 3 (as well as other applications) can be found in the link below.


Good day - today after a long night, I finally was able to install Firefox v3.6 in the appleTV silver edition (ATV1) - reason for this upgrade: FACEBOOK would not let me enter any comments (it removed the comment button)… So, after getting a really quick lesson on how SSH and UNIX Code works I finally got it to WORK PERFECTLY - if interested here is what I did:
I installed FIREFOX normally though the ATV: AppleTV navigate to Maintenance --> Install Extras and select Firefox
I then ran the FIREFOX v.2 in my AppleTV: nitoTV --> Applications  --> Firefox

Now you know that its installed (version 2) in your AppleTV, so lets take advantage and trick it by installing v.3
What I did was to rename this FIREFOX v.2 folder that FIRECORE seems to provide us (using FTP os SFTP):
Folder located in /Users/frontrow/Applications/
There is a folder called Firefox (so I renamed it FIREFOX2)
Why, it simply works if I install the v.3, since it installs in the Firefox folder, having this folder already taken with the v.2, it causes errors, I believe its locked or something does not allow for it to be changed, so renaming the v.2 to Firefox2 solves that issue.

I downloaded to my PC the FIREFOX 3.6 verison for MAC: http://www.mediafire.com/?imjd3yjnoog
I downloaded to my PC the TUNNELIER (BITVISE) software for SSH access: http://www.bitvise.com/tunnelier
I installed this TUNNELIER without any problems (WIN 7 verison is what I have)

I ran the TUNNELIER with these settings:

HOST: Use the AppleTV IP address (visible on the AppleTV in Settings --> General --> Network)
PORT: 22

USERNAME: frontrow
PASSWORD: frontrow

Clink on LOGIN button (bottom left)


from there you will see a TERMINAL SCREEN (black almost like the WIN COMMAND)
Here is where the lessons paid off:

*Understand this: first you need to place the file you download (FIREFOX.DMG -rename it, this way it makes sense in the following codes)
I did it via FTP to the APPLE TV folder: /Users/frontrow/Applications/
so this DMG file will be located there
**I imagine you can place it there too using the Bitwise SFTP windows that also pops up when running this TUNNELIER, I did it via FTP since I am used to moving files back and forth this way.

Next, in the terminal screen (BLACK BASED WINDOW),  here is a quick lesson of what you need to know:
If you type (hit ENTER to RUN or EXCECUTE THE COMMAND) …
you will see a LISTING (that is is LS stands for)

You will see a listing of the FOLDERS, and there you will see the APPLICATIONS folder (as well as others like DESKTOP, LIBRARY, MUSIC, ETC…)
To enter into a folder you must CHANGE THE DIRECTORY to that folders name, so type this code
It will change to that folders directory, but you will not know unless you see a LISTING and the code is:
you will now see the listing, which is different from the first listing, since we went into the APPLICATIONS folder (so now you know how to LIST and GO INTO A DIRECTORY)
Here you should see the Firefox.dmg file (that is the location where I placed it, so this is all based on that location)

MAC’s do three things, they MOUNT a software, then INSTALL a software and then UNMOUNTS a software – so expect to MOUNT this DMG file, then INSTALL and then again UNMOUNT it … so lets MOUNT
Type the following in the same directory where the firefox.dmg is displayed in the LISTING (in other words, the APPLICATIONS folder:
      sudo hdiutil mount firefox.dmg

This will mount FIREFOX (its kinda like EXTRACTING A ZIP FILE)
Now you will ask it to INSTALL, so type:
     cp -r /Volumes/Firefox/Firefox.app /Users/frontrow/Applications/

It will install the software:

TIP: you will see that after you MOUNT the firefox.dmg, it shows 3-4 lines of code, one of which is the location of the file, they place it not in folders but in VOLUMES, so the folder/volume should say: Volume/Firefox
This is why the INSTALL code above has that location … so now you understand what is doind, reading from that folder and installing to the desired location

Now, its to time UNMOUNT (like puting the ZIP FILE back together and removing all of its content), so type
    sudo hdiutil unmount /Volumes/Firefox/

You will see how it succefully unmounts the file, and your done!

Only thing pending is to ERASE either with SFTP or FTP the FIREFOX.dmg file and if you like the v.2 Firefox folder, which you named: FIREFOX2
located at /Users/frontrow/Applications/

here you should have the v.3 under the FIREFOX folder
and v.2 under the FIREFOX2 folder (the one you renamed)

Thats IT! enjoy, and excuse me if I could not explain myself in a clear manner, its the best I could do.

Firefox 3.6.17 Runs Great on the Apple TV.  Firefox plug-ins install & work.

3.6.17 Seems to have a lot less bugs, too.

Firecore should really upgrade their download to include 3.6.17

Estebanm’s installation instructions worked great.

I used WinSCP & Putty with the same results.

Esteban…Thank you very much for your post.

FYI, Firefox 3.6.18 is now available through the Maintenance --> Install Extras menu.


very nice but FF doesn’t do flash even though it’s installed !?!?!

Enabling Adobe Flash is possible, but there are a few extra steps involved.

Full details can be found here: http://support.firecore.com/entries/259320-enabling-adobe-flash