Why does Infuse struggle with TV Shows metadata?

Hi there. I have been using Infuse for a while on my iPad and love the app for playing back my local archive of TV Shows. However, I struggle quite a bit with getting it to behave in regards of metadata, and wonder if the community can help.

I’ve read the guide on the support site: Metadata 101 – Firecore Support

To my understanding of the documentation, if I set up a folder structure like the below image, I should be able to get Infuse to query themoviedb.org and detect the required metadata from their database:
image

However, despite the structure of the folders matching a known format, no matter what I do, Infuse is obsessed in trying to make this file match completely random movies, and almost always fails to detect this as being a TV Show. The only format that I’ve found which seems to work (and which goes against the defined support article) is to write the file names as “NameOfTheShow S00E00.m4v” (where the 00 represent the appropriate season and episode numbers), but this looks daft when I’ve put the files in a folder structure that should clearly identify what episode/tv show I’m looking for.

This also leads me to have hubris with the search box for “metadata editing” if I wanted to manually define it: the search feature repeatedly only searches for movies. Even if I type “The Crystal Maze” (using the example above in the image), Infuse constantly says “no search results”, which is frustrating.

If someone could tell me how to search to make it detect a TV Show, that would be helpful, as well as guidance on where I’m going wrong on naming the files. I have tried alternative formats suggested by the support article (eg 1-01 Episode 01.m4v or 01 Episode 01.m4v, but neither of these work).

NB: It’s worth pointing out that the files are designed to be played on a multitude of devices, many of which don’t have Infuse installed on them, meaning that trying to make the files fit Infuse on a single iPad is cumbersome when that format isn’t needed on those devices that just connect to the media server directly without Infuse.

EDIT:

In order to use this structure you will also need to include the episode name in the filename.

EG

Episode 01 - This is the episode name.m4v

Hi there, thanks for the quick reply (and approval of the OP).

I have tried this format as well, but Infuse still thinks that my file is Episode 01 from a documentary called “INTO OBLIVION” released in 2022, and not an episode of the Crystal Maze from 1990. Episodes of the Crystal Maze don’t have real names, its just “Episode XX” (where XX is the episode number in two-digit format), so this means the file name is Episode 01 - Episode 01.m4v.

Using “Edit Metadata” and searching the shows’ name does nothing, as I only get “no results found”.

Hmm, if the episodes don’t have actual names then this may present challenges for this particular series.

Are you able to use one of the other episode naming styles?

1 Like

I can use the format of doing The Crystal Maze S01E01.m4v which picks up the metadata correctly (variations of that format were the only ones that worked), but naturally naming files like that seems a bit counter-intuitive and also, that naming convention is obviously meant for situations where you create one folder and dump hundreds of files into the folder, with no organisation done on the file system.

FWIW, the same problem impacts the UK version of Who Wants to be a Millionaire: notably that its title on TMDB includes a question mark (which is forbidden in folder names on Windows) and the titles are just “Episode XX”, meaning those won’t be detected either (although Infuse seems to think that the files I have for that show belong to One Piece, despite having nothing to do with it lol)

Its a bit frustrating that I can’t just manually search for the metadata and force Infuse to use my selection from the search box (ie not having to detect it from file naming conventions and allow it to be picked manually via search): any ideas on how to make search work for that, or does it require some updates to the app from the developers’ end? :slight_smile:

I just did a quick test here, and this naming structure is working for me.

The manual edit option is available for select the correct series name (if Infuse happens to get the wrong one) but using that still requires using one of the supported naming styles to ensure Infuse knows which episodes need to be included as part of that series. Without this, you would need to go through and manually select a series, season, and episode for each individual file which would be quite tedious (and doing this is not available in the current version of Infuse).

If you want to keep this structure without the series or episode names in the title, you may also try simply adding the season number.

EG

S01E02.m4v

1 Like

Thanks for looking, thats honestly very strange!! I have used the same format but I’m only getting the aforementioned “INTO OBLIVION” documentary. The only differences I’m seeing is that your file is an mkv and has a double space after the hyphen, whereas my file is an m4v and contains no double space. Surely the use of an M4V wouldn’t cause Infuse to struggle with identifying the file correctly?

I switched to your suggested format (S01E01.m4v) but now Infuse thinks my episode belongs to a series called Bellator 1 from 2009. :joy: Using search in this format still does not return a single result for “The Crystal Maze” despite TMDB having 3 show entries that it could be displaying for results.

My Infuse app version is 7.7.2 (4781), which I assume is the latest version available on iPadOS. I’ve no idea why it struggles like this with identifying TV Shows, I don’t have a subscription that unlocks Pro, but I doubt that the lack of a subscription would have a material impact on metadata detections (I tried turning off “using embedded metadata”, but that made no difference to anything).

What type of streaming protocol are you using in Infuse to connect to the device where these files are stored?

Are you using a cloud service or something like UPnP/DLNA by chance? Some connections may have limited abilities to access the parent folder details, and it sounds like this could be the case here.

The files are stored on a Synology NAS in the local network. The iPad (and by extension, other devices like TV’s) connects to the NAS using UPnP/DLNA, which is used as a result of the Media Server package being installed on the NAS to provide multimedia access (that protocol allows access without needing to login with any username/password, and is automatically read-only).

Should I try connecting with another protocol instead, such as SMB? That is supported, but I’d have to create an account on the NAS that basically provides read-only access to that share (so as to avoid files being deleted by mistake)

Yes, using SMB would be a better option as it should allow these parent folders to be recognized. SMB would also allow you to utilize Infuse’s library features, which are not available when connecting via UPnP.

Read-only access is fine, as Infuse does not write anything to disk (unless you want to use Infuse to delete files from the server, of course).

1 Like

Thanks a bunch! I switched to SMB and the episodes are detected properly now. Only issue is that the app now keeps trying to create its own collections, rather than using a generic file picker that UPnP provided, but thats something I can deal with, as SMB is only for the Infuse app and won’t impact TV’s from accessing the files. :slight_smile:

Not sure how I will be able to fix the issue with “Who Wants to be a Millionaire” though, as the TMDB entry includes question marks that are not possible to set on the folder name locally, and I’m unable to manually assign the metadata to bypass this issue.

You won’t need to include the question mark in the filename, and this is the naming structure I have here which gets matched automatically.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.