Why do i get rarbg.com cover arts?

They are black with just the url on them. It seems to happen randomly. Until today just on 3 movies, but I dont see how I can change that. Even if I change the metadata to a completely different movie, it never changes the cover art. Any idea?

You have a .jpg or .png with that rarbg.com image stored in the same folder as the movie(s) you point out. Trawl through your folders looking for random .jpg files that shouldn’t belong. Even better, delete them and let Infuse retrieve cover art from tmdb.com.

Thanks for the quick answer. But no, my folder has only .mkv files in it. Also the folder above it. :frowning:

My guess is that you have embedded metadata turned on, and the covers are embedded inside the .mkv’s

I see, thanks for the answer. I can try that, when I get back home. I think you are right and I have that option enabled. The question is, what happens if I turn it off? Do I get the fun to manually find the correct metadata for hundreds of files again? Because if there is one thing with Infuse that makes me really mad, then its the not existing ability to save all the manually corrected metadata anywhere on my devices or in the cloud or whereever.
Whenever I want to reorganize something in my folders, I have to manually adjust hundreds of covers again, which leads to the point that I just cant reorganize anything anymore…

I feel your pain, but this is only about “embedded covers” (ie. inside the movie-files) and not those covers you include in the folder of the movie, so I’ve just added the covers I want as folder.jpg’s. Problem solved for me…

Ok, you chose the bigger “one-time” work. I dont have any jpgs for the movies. Its just that infuse doesnt really recognize much, even if it got a lot better lately. Still, the older movies (and I mean just regular blockbusters, nothing fancy), just dont get recognized correctly like from other, i.e. Plex.
So every time I just move a folder from left to right I start all from scratch. Maybe one day I have the patience to download all those covers, but last time I tried that when I wanted to overwrite a cover it didnt even work. But that might just as well be because of the setting you mentioned, so I’ll try.

You can avoid this by disabling the ‘Embedded Metadata’ option in Infuse, and using the Edit option to refresh metadata for the affected files.

Thanks guys. This worked for the 3 strange rarbg covers. I still wonder why infuse cant find the covers of so many very clearly and correctly named movies on its own. Its really a pain to do them all manually.

Any filename examples you are having trouble with?

They are all named just like the movie with dots between them and then some blabla about the quality.
Example: Legend.of.tarzan.german.blabla.blabla.mkv
But also without much blabla it doesnt find them.
Example: selfless.1080p.mkv
guardians.of.the.galaxy.german.mkv
Does it make a difference how much crap comes after the very clear name and if its a mix of dots and “-”?
I mean, sometimes if there are many movies with the same name, like “All inclusive” for example, infuse at least choses one from the list, even if its the wrong one. But in most of my cases I dont get a cover at all and when I chose edit I have no matches at all and have to enter the name letter by letter.

Infuse has a lot of smart filtering that will ignore out irrelevant words (1080p, HD, DVD, etc…) though just by looking at the few titles you listed I would guess the word ‘German’ is causing an issue. That is not a word we filter (there are plenty of film titles that actually contain this word) so instead of searching for Guardians of the Galaxy, Infuse is searching for Guardians of the Galaxy German, and not finding any matches.

I see. Well, in fact really most of the not found files include the word german. Maybe you could add that to your clever filter? :wink:
It would probably solve 90% of my problems and I hope I am not the only german user :wink:

Thanks for the feedback.

One thing we will likely have in a future update is the ability to have Infuse ignore certain words if they are placed inside a pair of special brackets. E.G. Guardians.of.the.Galaxy.[German].mp4 would allow you to get the correct title.

Ok. In my case sadly that wouldnt help, because I have to rename all movies, and if I have to do that anyway, I could just delete the word.
I am also not sure if thats really the main problem as 90% of my movies have that word in the title and infuse finds something like 90% of them. And then there are many movies without that word in the title that are not being found, like the aforementioned Selfless.
I dont know how they do it, but Plex does find all the movies or at least a lot more. I just dont like their app, though, so I always hope for updates from you guys :wink:

With regard to Selfless, Infuse is pulling the top result from TMDb, though this probably isn’t the title you are looking for.

One thing that helps in these cases (if you don’t want to manually correct them in Infuse) is to add the release year to the filename. E.G. selfless.2015.1080p.mkv gets the right info straight away. I wouldn’t recommend adding the slash as part of the filename, as that is considered a restricted character and may cause trouble streaming from some devices.

Make sure the film is spelt as on themoviedb.org and also include the year, eg

the.legend.of.tarzan.(2016).bla.bla.bla.mkv
selfless.(2015).1080p.mkv
guardians.of.the.galaxy.(2014).german.mkv

Thanks for all the help, guys. Turning off the embedded metadata option solved the problem of my topic.
As for infuse finding the correct metadata, maybe I explained my wish a bit wrong. I clearly know that I could name the files “better”, so infuse finds them. The point was that I dont like to do that, as its work for days and other apps like Plex find my movies and their metadata on the first try. So there must obviously be a difference in how its done and I was merely hoping for an update down the line, because I love the design of infuse and "re"fuse to use Plex :wink:

But that was also not even the main point I hope for, because for the moment I fixed all my metadata manually and adding new ones seems to work much better. The main feature wish would be that this “manual connection” that I make with the unfound metadata is somehow stored on my nas or ATV or cloud or something, linking to my account, so whenever I change a folder or rearrange something, or even copy my NAS, I dont have to eeeeeverything manually again.

Has anyone found a way to just remove the offending RARBG images without recoding the file? I has hoping I could just delete it from the VLC metadata editor like you can for all other (text-based) metadata, but it appears that isn’t possible.

You have to use a proper metadata editor. Most of them can edit the cover art.

Thera are many that are free (e.g. MP3Tag)