Which FW version for Plex?

I’ve just done a check and have all SHSHs for my ATV2 back to 4.4.  But, which was the last good working Plex version?  I’m pretty much over using my ipad or iphone to airplay to the ATV2 now, and just want to access direct.  I’m finding that later ATV OS versions have so much junk in them that theres hardly any disk space left to do anything and lots of buffering occurs so I’d probably rather go back further than 5.1, but am happy to receive advice.

Oh well, never mind.  I’ve discovered that the ATV has now to go through an activation process, and SHSH or not… mine will not activate unless its the latest.  Guess I am back to a non-jailbroken ATV2.

And… James… are you actually doing any work on getting a jailbreak for the latest or are all your efforts directed at Infuse for iOS?

Plex, reliably:

4.4.3

4.4.4

5.0.1

5.0.2

Untethered

Oh well, thats that then, I cannot get activation on any of them.  “Waiting for Activation” just sits and spins.  I gave up, and I’m not interested in getting the latest with Infuse, it was so unstable, thats why I stopped jailbreaking and installing the Firecore software.

You have used ATVFlash 2.3 to install Plex?

I cant even downgrade to an untethered version, so no…

Then what is this “Waiting for Activation” you refer to?

When I first tried, I managed to downgrade to 4.4.4.  It didnt complete properly (hence waiting for activation at the TV).  Everything I have tried since then has failed.  However, I found (finally) a reference to a downloadable .93 (seas0npass) so I’m now trying again.

 

[edit] ok, now the device seems to be stuck in DFU mode.  no errors yet, its just sitting there “Found device in DFU mode” and its not doing anything else, it seems.  I dont remember the jailbreak taking this long in the past…

 

[edit #2] Itunes restore script failed :frowning: Then it sent me to the season pass ipsw, which I presume I was to select and restore with.  Failed with a 2001 error.

Hmm, well nobody sdaid it was easy but there are many pitfalls and one of them - waiting for activation - is one of them.  You do not need to wait for activation, you just click on menu on the remote and it bypasses activation (I have never activated any of the 1000 or so I have done).

Of course, it’s too late now and if it really is stuck in DFU mode then youare in trouble.

Whereabouts in the world are you?

Of course I have just realised I still have all the copies of the ipsw files which seas0npass has jailbroken for me in the past.  It should install with an option-click (I’m on a Mac) so I’m giving that a good try.  No point trying to rejailbreak whats already done.  I have 4.4.4, 5.0.2, 5.1, 5.2 and 5.3 (which, interestingly, I never had to tether.  Wonder why…)

Guess I will be playing with this for a bit longer before totally giving up.

 

Next:  At first, it was stalling on “preparing for install” and now its stuck on “verifying with Apple”.  Its not erroring (yet) its just stuck.  I feel like I should maybe pull the plug and try again, and again, and again… but oh god this is tiresome.  More tiresome than just giving up.  Its just that I bought a lifetime licence so I’d kinda like to be getting my moneys worth, even if it is on the older FW versions (which I preferred, because the firmware isnt laden down with a bunch of crap I dont want)

I’m in Australia, and I’ve edited my post above to reflect where I am up to.  Not stuck in DFU mode anymore (I plugged in a power cord and that kicked it out) but also not getting a lot of joy.  And I just now got a 1603 error

Well, I expect that your 5.3 isn’t a jailbroken patched IPSW since Apple are still signing 5.3

If you are going to use the saved IPSW (and there is no reason why you should not) you need to put the ATV into pwned DFU mode before doing alt + restore.

You use iReb in Windows but I do not know what you use on a Mac.  You have to do this or you will get 160X errors.

All the files saved in the seas0npass directory have SP-Restore.ipsw attached.  Including the 5.3, so I’m thinking I was just lucky (or not, because that was the one that turned me off, when I didnt think I could downgrade.  I hated it).  I’ve just managed to restore 5.0.2, i think I was having either port or cable issues, because I changed both.  Wish I tried it with 4.4.4 but 5.0.2 will do.  Next trick will be to get a compatible ATVFlashblack.

5.0.2 is the same iOS version as 4.4.4 - it just has a different front end. 5.0.2 will do you just fine.

 

Yep, its all good, and I finally have Plex back after a considerably extended absence.  I didnt install Infuse, just decided to go with Plex.  I may change my mind at some point, but I find Infuse/media player a lot more fiddly