When is a micro-usb cable not a micro-usb cable?

I recently bought 20 Samsung micro-usb cable to send out with tethered jailbroken ATV2s.  So far 7 have gone out and not one of them works.  You can imagine the grief I am getting.

I have tried Belkin 1.8m micro-usb cable - doesn’t work

I have tried more micro-usb cables than you can shake a stick at.

The only one I have that works is a very flimsy little thing about 2 feet long that looks like it’s going to fall to bits any minute.

I have read that you should use one less than 1 metre long and my experience is bearing that out.

Can anybody please suggest a micro-usb cable that always works, preferably available on Amazon UK??

I thank you.




Some USB cables are just for charging (no data lines). You may have mistakingly got those. Also, from what I’ve read the tethered jailbreak has to be done on the computer that will be used to re-tether the ATV, the files can’t be transfered. Did you find a way around that? If so, how?

I didn’t find a way round it.  It wasn’t an issue provided the person who buys the Apple TV downloads their own copy of Seas0npass.

Any more views on the mico-usb cables that actually work?

Genuine Samsung Micro Galaxy i9100 / S2 don’t work.

So, nobody can recommend a micro-usb data cable that 100% works on restores of pre 5.x firmwares in iTunes?