What worked for me (seas0npass, atvflash 1.1.1)

I’ve been running atvflash for many months now, on my 1st gen and now my (2) 2nd gen apple tvs.

 

Every time, I’ve had some issues, but with the new seas0npass supporting 4.4.4 I thought I’d share what worked for me.

 

Keywords: DFU mode, Error 1602, 4.4.4, untethered, atvflash 1.1.1, Mac Install, Lion FullScreen

(Note I did this on my 2011 MacBook Air.  I don’t use Windows for Apple stuff so this is just a Mac instruction guide :slight_smile:

  1. You're going to wipe the apple tv anyways doing this, so start by making sure you're clean.  Disconnect the apple tv from the television and connect only the usb (no power) to your computer.  When iTunes appears, tell it to restore to the latest software update (in this case, 4.4.4)
  2. Wait patiently for the apple tv to be restored and wiped.
  3. When it comes up and says you can disconnect, do so, and quit itunes.
  4. OPTIONAL (but caused a problem for me in lion/fullscreen) : open itunes.  REMOVE FROM FULL SCREEN MODE.  quit itunes.  open itunes again, it should NOT be in full screen mode.  exit itunes.)
  5. Download and open seas0npass
  6. Select "Create IPSW"
  7. When it asks you to connect the apple tv, do so with these three steps (IN THIS ORDER)
  8. First, connect the USB cable
  9. Second, connect the power cable
  10. Third, press and hold menu/play for seven seconds.
  11. No need to wait for steps 7-9, just do it in that order.
  12. When you press for 7 seconds (step 9) the light on the apple tv will blink VERY VERY fast.  When you let go, in DFU mode it will blink VERY fast (not VERY VERY fast, just VERY fast).  Then, finally, seas0npass will see the apple tv and continue
  13. seas0npass will upload some files to the apple tv, and then launch itunes to restore the software again.  itunes will load the software/firmware from the ipsw that seas0npass just created, and seas0npass will script-command itunes to load the file.  (this failed for me when itunes was in fullscreen mode.)
  14. itunes will "verify with apple", "restore software" and then "restore firmware".  restore firmware will FAIL with error 1602.
  15. At this point, disconnect all cables from the apple tv and connect it to your television again.
  16. You can now set up the apple tv.  wifi/ethernet, name the apple tv, etc.  Easy!  Yes, it failed, but ignore the failure :)
  17. Once you have the apple tv setup via the tv interface, run the atvflash installer.  It will scan the network, see the apple tv, and let you install to it.  easy as pie.
  18. run the maintenance "manage extras" to install the media player.  connect it to your NAS (SYNOLOGY FTW!) and play your media collection on your apple tv.  awesome.

A good detailed list of the steps that you took.

To save a bit of time, it is worth pointing out that steos 1-4 are not needed as step 14 wipes the system anyway!   Still, I guess they do not do any harm (other than take up a bit of time) and they do get one familiar with parts of the jailbreaking process.

Will try this. It is the 1602 error that I have seen 2 out of three times… Before this current JB, I have had no problems with tethered or untethered except that my BlackMAcbook has not been able to do it since 4.2. IMAc has always worked either way.

OK. Jailbroken and with my BlackMacbook. However, with the newest Seasonpass .8.1. not the 8.    All went well, no error message, but during the last verification stage with the power plug in it was hanging, so I took achance and unplugged the  ATV2 poer cord and bingo SUCCESS. Perhaps with this update to ?Seasonpass to fix the full screen issue, it can be a true untethered break. No to load XBMC and  hope all stays well.

I have been using aTV flash since the first beta was out and other than having problems early on getting into DFU, it’s worked beautifully.  Now that I’m trying to update the version with the untethered Seas0nPass, I get this exact error.  You gave me hope since you mentioned getting the 1602 error.  However, when I run the aTV Flash installer, it finds my aTV2 but tells me it has not yet been jailbroken.  Getting frustrated.  Any help would be great.

Hey i just keep getting Error 9 codes even when i just try to restore the ATV2 through itunes… would a cord cause this…?

I’m sure you have, but will ask anyway;, have you checked to see what an error 9 code is? James has a link to the error codes in a thread. Can you try your cable with another device? At what point does the process fail. When do you get the error code?  If scripts have gotten loaded to the atv2, then it is not a cable problem. I once had to do a reinstall of ITunes to get a Jailbreak done. That came from a thread here at Firecore.

Justin case: Error 9: This error occurs when the device unexpectedly drops off the USB bus and communication stops. This can occur if the device is manually disconnected during the restore process. This issue can be resolved by performing USB isolation troubleshooting, using a different USB dock-connector cable, trying another USB port, restoring on another computer, or by eliminating conflicts from third-party security software.

Ok well i will buy a new cord and try again later today, I will also try Re-installing Itunes. I’ll post back if i have success, Thanks alot guys

Ok well i tried everything and anything couldnt even get it to restore to factory settings, so i called apple they basically said its a POS, but i just bought it, so ill be able to take it back and get a new one hahahah cripes. hahaha thanks for all the tips

 

Well, that at least is good news. Now you will be  an expert at the git go with a new device. :wink:

I noticed something VERY important when jailbreaking more than 1 appletv. The status LED light must be flashing about 1 time every second or so (not too fast but not steady on). There are several status lights

 

http://support.apple.com/kb/HT4380

 

There are also 3 different flashing LED statuses – extremely fast (when you are restarting the AppleTV), once per second when it is starting up, and a faster flash 2 or 3 times per second.

The DFU mode must be entered without a power cord (only miniUSB cable attached) and with the LED light flashing roughly the same speed as when AppleTV is starting up – once per second or a bit faster. Any other status LED light (no LED, fast flash, flicker) will yield an error on restart.

 

I’ve found that attaching both power and the miniUSB together and launching itunes and THEN disconnecting the power can get my AppleTV in the right mode for a DFU to be activated (MENU+PLAY for 7 seconds). You have to have the flashing LED to get seas0npass into the DFU mode properly, and power must be disconnected with only miniUSB active. I also have itunes turned off and let seas0npass script launch itunes.