What the heck, why isn't my jailbreak working? *SOLVED*



Today I decided to update my ATV 2 from 4.4.4 untheterd jailbreak to a 5.0.2 untheterd jailbreak in order to get airplay streaming to work from my mac.


So I first tried to update from the menu on the Apple tv (knowing that this would break my current jailbreak). But i didn’t work. So then I plugged the ATV 2 into my mac, but iTunes could not find and restore it. So then I had to manually download and install the 5.0.2 firmware. It worked.


I downloaded seasonpass and let it create a new ipsw-file for me. Then I put the ATV 2 into DFU mode and followed all the instructions. When it tried to restore in iTunes i got a error message in Seasonpass that said “Itunes restore script failed” and then I got to select the newly created ipsw file in finder. Then nothing happens, so I had to “option”-click on the restore button in iTunes in order to get it to restore. And everything goes well after this.


But when I plug the ATV 2 into my tv I dont get the FC logo in the corner, thereby I am not jailbroken.


What is happening?


I am doing everything as the guide says!


Help me!




Now I have tried to do a complete restore and do the entire process again. But it still doesn’t work.


Every time i use seasonpass i get the itunes error, and everytime i have to manually choose the ipsw file. Is seasonpass supposed to do anything after the restore-process? Because it just stops after i have pressed “ok”

This solved my problem:

After many atempts i realized that I used the wrong ipsw file. Seasonpass put my jailbreaked ipsw file in the library-folder, which is hidden in Lion and Mountain Lion. When I tried to option-restore in Itunes i used the tethered ipsw file which was located in my documents folder.

When I realized this, I sucessfully restored my atv 2 with the seasonpass ipsw file located in the library folder!

I have the exact same problem. I’ve tried it twice with the same result??

The device needs to be in PWNed DFU mode to flash the jailbroken IPSW. This can be achieved by using iREB on Windows. Unfortunately there isn’t a MAC equivalent that I am aware of.


Okay, i’m able to run Windows virtually via Parallells, although, it does not seem to work, iREB just tells me that I’m not able to enter DFU mode…
When i jailbreaked this ATV before, on 4.4.4 this wasn’t needed, so why now? What’s wrong?




Oh, maybe I should also say that I have itunes 11, is it maybe what’s causing the trouble?

So I have done it serveral more times, and this is how it goes:


Step 1: Open seasonpass 0.8.6

Step 2: Create IPSW file of 5.0.2

Step 3: Put ATV 2 in DFU mode; it is detected by seasonpass and some file is uploaded

Step 4: Seasonpass opens Itunes 11 for a restore; error message “Itunes restore script failed” in Seasonpass

Step 5: Finder pops up and i get to chose the newly created IPSW; then nothing happens

Step 6: In Itunes i alt-click on the restore button and once again choses the newly created IPSW file

Step 7: Itunes sucessfully restores from that file

Step 8: I plug it into my tv, and it is not jailbroken…

Please see here for a workaround. http://forum.firecore.com/topic/9283