What i learned after successfully Jailbreaking my ATV2

I attempted to Jailbreak my ATV2 last night and although i was successful, it took about 5 attempts to do so and i hope that my post will help others in their attempts.

My equipment includes: a silver MacbookPro - 2.33 ghz with 3 gigs of Ram

an iMac i7 that lives in a spare room/office

My ATV2 which lives in the lounge room 

Seas0nPass and ATV Flash

Looking back, my first attempt, i lightheartedly looked at the picture tutorial on this site. I thought i had successfully JB my ATV using my laptop, however i realised i had not, when i could not copy my aTVFlash files to my ATV2. So, using the same laptop, i used iTunes to restore to the factory settings, however, during the install, iTunes displayed a warning and told me that it could not restore the aTV and had the code 1611.  I tried again and the same thing happened and i thought it was bricked.  I then plugged the ATV2 into my iMac and attempted the restore and that worked fine. A brand new ATV2.

I then read the picture tutorial properly and realised i had not seen any screen relating to iTunes appear. So again, i attempted to JB using my laptop. After it went through its unzipping and everything else, again i did not see iTunes launch. So i restarted seas0npass and also opened up iTunes aswell and had the 2 screens next to each other. This time i saw iTunes being selected but i did not see it choose the new file that seas0npass had created for me. I continued through the tethering stage and tried installing ATVFlash, but was unsuccessful.

So i had itunes restore to the default, and thought that perhaps the problem lay with my laptop. So i brought my ATV2 to my iMac, followed the instructions for seas0npass again and this time, i saw iTunes open up, it tried to look for the file that seas0npass had created and failed. It asked if i could locate it, and i did. It then continued on and restored my ATV2. I then had to get my ATV2 from my lounge room to my office, so i just unplugged all the connections, went upstairs and launched seas0npass on my laptop. I then entered the tethered option, put in the usb and the power, pressed the buttons and hoped for the best.  I dont believe there is anyway of telling if the ATV2 has been Jailbroken, but the only way i would find out, was if the aTVFlash files copied accross.  I opened up the application on my laptop (i had disconected the usb cable by this stage), launched the app, and all worked fine. It copied it accross.  I launched ATV2 and saw i now had the maintenance option and i had a Jailbroken ATV2.

So my problems were related to my laptop. Perhaps there is a minimum requirement when doing this kind of thing... but i used 2 macs to get it to work.

I hope this helps some people out there. If you get 1611 numbers displayed in error messages..all is not lost. Try a newer or different machine.

Good luck.


thanks for your story.

My iTunes will launch but will not restore from the created ipsw file (step 5).

iTunes will just sit there and SeaonPass will say it wasn't successful. I'm not sure how you selected the file manually though.

@Chris | I have the same MacBook like you and had a similar problem. I had to plug in the power for a second to enter DFU mode, otherwise iTunes did not start up to do the restore process. But now all works fine. Except XBMC which is, as far as I can see, a complete waste of time …

Greez Hardy