What do I do about "firmware restore failed?"

Hey all. I just upgraded my atv2 to 5.3 and am using seasonpass 5.3 on a mac. after uploading the ipsw i got from ipswdownloader.com, I start going through the process, it creates the ipsw successfully but after I connect it and put it in dfu mode, it says “firmware restore failed?”…no error number or anything… I don’t know what to do. 

Mine does the same, I’ve opened a ticket with FireCore and sent them a logfile. The logfile mentions something about a missing lib file, so I suspect they might have published a broken seas0npass executable?

I have same thing with 4.4.4

Researching now, I have a suspicion… Do any of you guys by chance have homebrew installed?

I redownloaded 9.3 and it worked, but now after i plug it into my tv, the apple logo comes up and then screen is blank

That sounds like it didn’t work. Atleast that’s how mine behaved after a failed restore.

 

5.3 is a tethered jailbreak. Make sure you tether it and not unplug power.

My experience was from firmware 5.0.1 to firmware 5.2 using seas0npass 0.9.4.

I managed to get it to work by copying all .dylib files from Seas0nPass.app/Contents/Resources/bin/idr/ to /usr/local/lib (which I think only exists if you have installed homebrew or otherwise customized your system).

.93 did work, I was just dumb and forgot it was tethered (thus, ths dark screen issue)

I  am getting the same issue. Still no luck after downgrading to Seas0nPass 0.9.3. 

What iTunes version are you running?

Latest version of iTunes is 11.1.1.

But are you guys all really trying to jailbreak your ATV’s using IPSW’s downloaded from "IPSWDOWNLOADER.COM?

Really?

having the same issue. have restored and updated atv software a couple of times now, prior to trying jailbreak sequence. it is running now the latest 6.0. is this the problem, as jailbreak mentions v5.3?

Version 6.0 is only a problem if you wish to jailbreak and still have the new Itunes Radio feature.

Unless something has changed in the past 12 hours, Apple is still signing 5.3 and that is the version to use with your 6.0.  By the way, you didn’t need to restore and update in order to start a 5.3 jailbreak; Seasonpass is all too happy to update any version to 5.3 – which is tethered.

You should not have a problem jailbreaking a healthy 6.0 unit.  Make sure that you’re using the latest version of iTunes (11.1.1) or you’re likely to have problems.  And a quality Micro-USB is critical.  But if you can enter DFU that is likely not an issue here.

Persistence is sometimes all it takes.  

If you have the option, I find that using a PC for jailbreaking purposes works best for me with SP 9.3. But it is not a prerequisite with 6.0 to 5.3.

Try again… and again if you need to.  For sometimes inexplicable reasons, repeating the same (correct) steps that were failing eventually results in success.

Gypsybox solved his problem with Seasonpass 9.3.  You should have no issues doing that either.

No, of course not! I am using the default ipsw downloaded through seas0npass. Just cannot get this thing to work through iTunes. I am also using the newest iTunes 11.1.1. Just cannot get the iTunes script to work properly, even tried on 2 separate macs with the same issue. Anybody have any suggestions?

i downgraded os to 5.3 and still no success. i tried a tethered boot but, although it said it was successful, when i went ot install atvflash it said it wasn’t jailbroken. I think will try another computer. I also noted that itunes doesn’t restart to complete the restore process when using IPSW, could this be the issue?

I’m having the same issue, my itunes doesn’t even try to do a restore process,  seas0n pass just goes to “firmware restore failed?”

Does anybody know why I cannot manually “restore” my atv2 with the patched .ipsw file created by Seas0nPass? I am using the ipsw located under /Library/Application Support/Seas0nPass/Firmware/AppleTV2,1_5.3_10B809_SP_Restore.ipsw and still having trouble. Is there some trick to manually installing a teathered firmware version (yes, i am very familiar with a tethered boot)?

I am pretty familiar with jailbreaking my atv2 and have found my way past dozens of roadblocks over the years, but this one is being particularly difficult. No matter what i do, i just can’t find a way to get a jailbroken version of 5.3 to install. Any advice would be greatly appreciated

You could always try using a windows machine! i have never had much sucsess using my macbook but have never had a prob with windows… maybe worth a try!!

After two days and repeated attempts with two different mac computers I call it quits. Having been a ATV Flash user since the early days with the silver and the black versions I am well aware of jailbreaking an ATV. This past upgrade has made me regret even trying. My most recent attempts have left me with a blinking light upon start up that doesn’t go away (after an untethered jailbreak) or the tethered jailbreak that says it is done but results in nothing when i try to install ATVFlash. Restes to 5.3 or even 6.0 do nothing to vary these results (although I have lost the “firmware restore failed” warning). My only last resort is to try the PC side with my parallels installl. I am feeling adventurous so stay tuned!

According to FireCore, my specific problem was solved in a new build, so redownloading Seas0npass today might help some of you.