What Am I Missing?!

Hi there,

As an enthusiastic and thorough instruction follower, I can’t, for the life of me, understand what the heck I’m missing when it comes to JBing my AT2.

I do notice that for all the instructions I’ve read, iTunes is supposed to automatically launch and restore my AT2 while I’m in DFU mode. I end up having to manually launch iTunes and restore myself. No part of this step has ever worked the way it’s supposed to which is making me wonder if this is the vital step that’s throwing off the entire process.

Another thing I just might be screwing up is when to have just the USB, the USB and power, and eventually the HDMI and ethernet connected.

Other than that, is there anything that I can try to keep an eye out for that most people miss without realising?

I’m going to go through the entire thing again and give it a 13th shot. I’ll pay careful attention to the steps I’m taking so I can maybe put them here, too. Maybe something glaring will be discovered.

In the meantime, any tips or hints? 

Thank you!

Oh, and in case this comes up, here are my versions:

Mac OS: 10.6.8
Apple TV Software: 6.0 (6646.65)
Seas0nPass: Version 0.9.4 (765)
iTunes: 11.1.1


If you have access to a PC, try with SP 9.3.  I found no joy with the new MAC version 9.4.

You might find that the whole process completes without an issue.  The PC solution seems to work for most.

When iTunes opens, hold the shift key, click on “restore.”  iTunes will automatically go to the Seasonpass folder (in Documents).  Click on the 5.3 IPSW and iTunes will complete the rest.

Hope this helps!

I don’t have a mac but I read that Seas0nPass Version 0.9.4 doesn’t use itunes. The earlier versions did though and that’s probably what you’re reading.

Apple firmware 6.0 isn’t jailbroken yet, you’ll have to right-click “create ipsw” in seasonpass and choose 5.3… it’s tethered, so be aware of that*


*if you have any previous blobs saved for that unit you can also downgrade to those.

Ah! I didn’t realise I could chose my firmware. I’ll try that! Unfortunately, we’re a house full of Macs, so I’ll have to try to work with what we have…

It looks like there are three variations of the 5.0 firmware:

5.0 9B179b
5.0 9B206f
5.0.2 9B830

Is there any particular one I should choose? 


Sorry I corrected it, but I meant to put 5.3 not 5.0.


Also, if 9.4 doesn’t work, do as MaxieWagner  wrote and try with SP 9.3 also

Gotchya. Downloading the 5.3 right now… 

I’ll see how it works out with the 9.4 then will revert to .3 if it doesn’t work. Stand by…

And, thank you!

There is a 9.3 MAC version… but I don’t know where to get it. I did a quick 3 minute search but couldn’t find one.

p.s. Seasonpass would have downloaded that 5.3 firmware for you during it run.

First time entering DFU mode and I got a “Firmware Restore Failed?” error. So, I manually went into DFU mode from the S0P dashboard and now I’m at the “Tethered boot complete!..” window but iTunes is not loading. With the 5.3 am I supposed to see it load automatically?

Should I go into iTunes and restore myself now? 


*EDIT: Actually, I just opened iTunes myself and it doesn’t even recognise my ATV. (yes, it’s connected via USB).

Maybe I’ll try to find 9.3…


If you used the 9.4, then you shouldn’t have to have itunes do anything.


Since you got the tethered boot compleated messege, I believe you were done at that time. Remember with tethered boot you CANNOT remove the power cord from the device or you’ll have to re-tether. So, once done just remove the USB then plug the HDMI cable into it and the TV.

After your message I didn’t end up manually restoring iTunes myself. I just plugged in the HDMI and connected the ethernet and power, but when ATV came up, I don’t see the temp FC logo and all the movies want me to pay. So, it didn’t work.

Question, at what stage is the power cable supposed to be connected?

EDIT: I just tried boot tethered again, this time with the power cable connected. When I got the complete and disconnect USB window, I did that, then connected the HDMI and the ethernet. Now, all I see on my TV is a blue screen. Plugging in the HDMI doesn’t make my television recognize ATV now. I just don’t get it…

What’s worked for me is:

  1. Tether boot device

  2. Plug Power cable in

  3. Unplug USB cable

  4. Plug in HDMI cable


You can try the jailbreak again if you still don’t see th “FC” icon instead of the settings.


As far as getting unpaid movies and TV put XBMC on it once jalbroken.

I found a guide that I follow and had complete success… http://www.xbmchub.com/blog/2013/08/14/complete-guide-to-installing-xbmc-on-the-apple-tv-2-running-5-2-or-lower-with-ifaith-blobs-and-configure-with-the-wizard-addon/ you can skip to step 23 (part 2)

Still didn’t work; I think I’m going to restore the ATV2 to factory settings and start from scratch with the JBing. With that being said, when I click Create IPSW from the Seas0nPass dashboard, and choose 5.3, should the power cable be plugged in at that time? Or, just the USB.

Thanks again.

Confusingly, some people have actually had success with it being plugged in even though the guide doesn’t say so. So you may have to try it both ways.

I’m going to give up for now. I’ve tried it at least 5 more times even with factory resetting the ATV a couple of times. I’m begining to think that it’s the ATV Software 6.0 I’m running. Maybe that’s throwing it all off. All the instructions I’ve read are for lower versions.


EDIT: I just found this post that James made in Sept… 

6.0 (iOS 7.0 - 11A470e) - no jailbreak yet

I guess that’s my answer…?
I can’t install 5.3 IPSW if my ATV2 has 6.0 software. 

You can go from 6.0 to 5.3 still.  I did it today using seasonpass version 9.3.  The apple tv got stuck in DFU mode the first time.  The 2nd time i left the power cord in during the jailbreak and was succesful.


Paulie, really? What is your trick then? Are you doing this on a PC or a Mac? And, your process doesn’t automatically launch iTunes, either?

If it’s not too much trouble do you think you could jot down your steps from beginning to end? Including when you plug/unplug the USB and power cable?

If that’s a lot to ask, that’s okay, too. :slight_smile:

I used a mac to jailbreak. I did use a pc to tether boot after but that shouldn’t matter.

Itunes launched by itself. 

  1. Launch seasonpass version 0.9.3

  2. connect the apple tv with the usb cord and power cord.

  3. right click seasonpass and select save firmware signatures. (this step failed but i still was able to jailbreak)

  4. right click seasonpass and select 5.3 

  5. after its complete follow the tethered boot instructions.




do u have any of these saved or are these versions on the seasonpass server

5.0 9B179b
5.0 9B206f
5.0.2 9B830

Is there any particular one I should choose?  [/quote]