What am I doing wrong?

Some of my Blu Rays are uncompressed files from MakeMKV backups. When I play them on my Apple TV (newest one)…I get the swirling whirlpool frequently and the video doesn’t play continuously. I have an older Apple TV…and I get the same whirlybird with it.

If I go to my iphone and play the same movie over WiFi…it works fine. There are no delays. If I play a compressed movie on both Apple TVs or IOS handhelds…they all work fine.

The older Apple TV can link up with SFTP and for some reason I can’t link with SFTP on the newest Apple TV…only SMB.

All devices are hard wired with ethernet into a nearby Google WIFI station. The google network check says I’m at blazing speeds!!!

So…what am I doing wrong on the Apple TV’s

I have a pretty fast iMac and the movie files are all on an external hard drive USB 3.0

Have you done a speed test from within Infuse with one of the problem files?

I did and also got the swirly

So you didn’t get any numbers like speed in Mbits?

I take that back

I did try to run speed but I couldn’t figure out what do do when I opened the MakeMKV backup folder.

If I speed test a compressed file - I’m running around 40-45 mips

40-45 is pretty slow. What happens if you use regular FTP? SFTP isn’t needed in an internal lan at home. The encryption will just add unnecessary overhead.

I tried FTP…but I have Catalina and the FTP option is gone. I also have two Apple TVs…I wasn’t sure how to connect two.

I did try FTP on the newest one. But there is no FTP option with Catalina. I also tried SFTP in Cyberduck.
The on-line Infuse help section, I believe, is for older MAC OS and cyberduck screenshots are old as well.
I get identical errors it I use the IP address instead of AppleTV.local

See attached screenshots of my attempts

You can’t connect to an AppleTV with FTP. Both Apple TVs will connect to your iMac or whatever device is hosting your content.

Now I’m confused. Why can’t I use FTP?

Apple TV is not a server, it’s a client. The Apple TV has to be the one to connect to the server using FTP it’s not a two way street.

This is what I was doing

That is for Firecore’s other product ATV Flash and is used with the older generations of Apple TV (2nd and 3rd gen) not for the current gen 4 and 5 Apple TVs and also the new version of Infuse.