Weird Audio in ATVfiles

Since I updated my ATVflash to the newest version, I have been getting some weird audio problems with .avi files in ATVfiles. The video plays normally, but the audio is “rachety”, it sounds like the noise an old film projector makes. The files play normally in Nito, but I am not as fond of it as ATVF. Is this the same issue people have ben describing with ATVF and AC3? Is there something that I can do, in terms of settings, to make the audio come through, at least in stereo if not surround?

You can try toggling the ‘AC3 pass through’ option on/off in Files > Settings. This should solve the problem.

How can I get my xvid files with AC3 to work then? I have the same exact problem.


I have a similar problem. Switching AC3 Passthrough settings does nothing for me. Overall this version ATVFiles is really bad as I also have the crash problem on rewind of AVI files.

I’ve been having the same problem (running the ATVFLash 3.6.4) . By trying to observe the difference between AVI file that has good sound and another that doesn’t it seems that if the Audio Bit Rate greater than 192Kbps it won’t work. Here are three examples:
This one works (example 1):
Resolution…: 720 x 304
Framerate…: 25.000
Video…: 2311 Kbps
Audio…: 192 Kbps (LiNE)
Language…: English
Encoder…: oZi

These two don’t:
Example 2:
Audio Codec …: AC3
Audio Bitrate …: 448 kbps

Example 3:
Audio Stream
Wave Type: 8192 - AC3 Audio
Avg. Bitrate: 223,99 kbit/s
Sample Rate: 48000 Hz
Bit Depth: 0 Bits
Channels: 6
Audio Delay: 0,00 s

Does anyone have any idea of what needs to be done? I was about to give a try to the 4.0 version but saw the post that Apple released an upgrade and the ATVFlash team is working on updating the patch…

It is probably because the avi files are multichannel. I am having the same problem. Haven’t found a solution besides playing them in XMBC. But I hate playing my movies in a program inside a program. Just want to use Nito.


Here is the trick. Restore to factory settings.Upgrade to 3.01. Reinstall ATV Flash 4.02 - rebooting the finder every time you install an item. Only install the nessesary things. Now everything works.


A buddy of mine helped me figure out the following solution:
Go to Nito/Settings/General and toggle File Playback Mode to mplayer and problem is solved. Apparently when set at Mixed Nito sometimes tries to use Quicktime which doesn’t seem to be working.