WD My Passport Wireless Pro uPnP/DLNA will not connect only with other app

I know before I start some people will say I do not know what I am talking about. Do not care.

Infuse Pro 7 refuses to connect to my WD My Passport Wireless Pro locally/wirelessly through uPnP/DLNA. I believe it is because I can’t select a port for it in advanced. It just has a field for mac address and that is it. The other app, nPlayer Plus works. Though it inputs the port 9000. So that is why I am thinking why Infuse Pro will not connect.

Anyway to fix this?

I would just use SMB/CIFS to locally/wirelessly to connect but it is too slow even for my local 4k , 80 GB video files. I tested it repeatly in Infuse Pro with speedtest tool.

All I know is when uPnP/DLNA locally/wirelessly in nPlayer Plus is used it does not buffer the 4k, 80 GB video file.

When SMB/CIFS is used in nPlayer Plus the same file buffers.

Remember all of this is local just connected to that drive over local wireless.

What did you get for speed on this file? Which SMB protocol did you use? I take it you can put the drive where every you want (close to the device running Infuse) so that shouldn’t be a problem but the SMB settings can cause problems with some devices.

40 to 60 Mbps

SMB Auto

I want to use uPnP/DLNA

When I click save after 30 seconds to 1 minute

When you use these protocols you lose much of the benefits of the Library in Infuse. You’re far better off with SMB, FTP etc.

When you got the low speeds in SMB what WiFi band were you connected with? 2.4 GHz or 5 GHz? Was the drive running on battery? That will also contribute to low speeds per their manual.

You may also want to try setting up an FTP connection.

On the SMB connection you can also try setting it to SMB 2 or Legacy in the Infuse settings. Those two settings are faster for many users over auto.

I don’t want library.

5 GHz. No.

Ok.

Does not work still buffers some.

When you add the WD drive are you selecting it from the list of “Available Shares” or are you selecting “Other” and filling in the info?

The standard UPnP ports are 1900 and 5000, and unfortunately it’s not currently possible to set these manually for UPnP/DLNA shares in Infuse.

However, it looks like this device also supports FTP. Have you tried enabling this and testing the speed?

You can also try adjusting the SMB version in Infuse to see if this makes any difference.

Ok I tried FTP it works so far better thanks. At least the speed test now there is no playback of any videos at all over FTP weird. :frowning: It says An error occurred loading this content.

Yes tried different SMB versions. Never works well with SMB sadly.

Overall still prefer UPnP/DLNA sense to me it is more secure. I could be wrong. Though this won’t work in Infuse Pro.

Available Shares

I wish there was a way to disable artwork and stuff on Infuse Pro and just make it a dumb version of a media player just showing file names.

Libraries: Uncheck all Shares
Settings / General / Metadata: TRASH

Adjust Settings

  1. Show Filenames: ON
  2. Metadata Fetching: OFF
  3. Embedded Metadata: OFF
  4. Sort Order: Filename
  5. Show Poster Titles: OFF

Libraries: Pre-cache Images: OFF
Libraries: Recheck all Shares

User: Use the Folders Browser

Optimally: Enable List View