WD My Passport Wireless Pro issues with Infuse in iPad Pro

Using the WD Wireless Pro as a Plex Server (using built-in Plex functionality in WD). I have an iPhone and an iPad Pro (2018 12.9"). My iPhone and latest Infuse and Plex apps works fine. My iPad works fine with Plex app. But with Infuse on my iPad, it only works when the WD is connected to the internet (so that the iPad has internet). I have specifically turned off the WD “Connect to Internet” function as many places we want to use this (while traveling on a plane or in a hotel room, etc.) will not have internet.

With my iPad connected to the WD WIFI (5Ghz band, no internet), I launch Infuse and can choose from My WD Passport or OURPLEX (our Plex server at home). I choose My WD Passport and I immediately get “An error occurred. Sorry, Infuse encountered an error while trying to connect.” Plex app works fine. Reconfigure the WD to connect to internet, and turn off and back on iPad WIFI (5Ghz WD Wifi) so the iPad has an internet connection (through the WD) and launch Infuse. Works fine.

So, on my iPad, connected to the WD WIFI and no internet, Infuse gives an error and cannot connect. With internet on the iPad and connected to WD WIFI, it works fine.
On my iPhone, Infuse works fine with or without internet.


Just a guess but wouldn’t the iPhone just user cellular data for the internet access needed when no WiFi is available? Since the wireless pro doesn’t have cellular backup it needs to have the internet access available. I would also guess this is to due the necessary icloud sync.

Would turning off iCloud sync in Infuse help? What does using iCloud sync buy me?

The whole point of using a wireless hard drive to stream media is to be able to use it while mobile. And mobile doesn’t always mean having high speed internet. While on a plane or remote locations, this drive should be able to stream media to Infuse using the built in Plex. It used to, but now there are issues if there isn’t internet, so some feature or something was added to Infuse that is breaking this.

Today, I tried Infuse from my wife’s iPad (which worked on WED from my car, which was parked waiting for someone so no internet) and tried to choose my Wireless Passport Pro, it said “An Error has occurred/ A token has expired. Please login again”. Can’t login, because no internet!!! What is this token, and why did it expire? How long is a token good for?

I turned on internet access through the WD Passport Pro, and reconnected again, and Infuse worked properly. The need for internet is killing the usefulness of the WD Wireless My Passport Pro. If I can’t use it on a plane or remote locations, it’s no good to me and it used to work troublefree but not now.

The tokens are required by plex for third party clients to authenticate with plex. It’s not an issue when you have internet access it isn’t an issue. The first party client doesn’t seem to be affected as much (in my experience). It might be easiest to just ditch Plex and use SMB connections.

Thanks for the reply. So you’re saying it’s the Infuse app itself needing a token from Plex to continue to access Plex services?

Do you know how long a token is good for? I can easily fire up the Infuse app before traveling to make sure it has a token, but it would need to be good for 7-10 days before needing another. But, considering it was working on WED and now (SUN) it’s expired, that doesn’t sound like the case.

SMB would work, but we would lose that wonderful, rich interface that Plex gives.

Yes all their party clients need a token to authorize them with your plex server. I have no idea how long a token lasts for or what conditions require re-authentication. Your question would probably be best presented on the plex forums. These guys know plex inside and out.