WD My Cloud Home connection error & set up help

When trying to connect to my new NAS WD My Cloud Home via SMB Infuse sees my NAS but when connecting I only se Public folder (wich doesn’t exist on my NAS) and when entering the folder I either get connection error och Folder empty message. I’ve tried googling it but came up empty handed. It seems tom be a difference between the old WD MY Cloud and the new 2017 My Cloud Home in this case.


1 Like

I’ve got the same exact issues and I can’t solve it.

It sounds like Infuse may be connecting as a guest.

Have you entered both a username and password in Infuse?

Yes, of course.

Yes I have tried that with no sucess

i have the same problem only the Public file

For me the same. Any solutions or workarounds for this issue?

Has everyone that is only seeing the “Public” folder also set up new shares in the WDMyCloud browser interface and created users with the correct access privileges for those new shares?

Sorry if this is a silly question for some but I’ve seen folks try to use the MyCloud without setting up new shares and privileges.

How can I do this? The only thing I can do from the MyCloudHome is create a link to share the folder. Also, I’ve tried to enter the WDMyCloudHome from the IP adress but this shows on the browser “{“key”:“notFound”,“message”:“Not Found”}”

The “MyCloudHome” seems to be a world different that the “MyCloud”. On MyCloud you can access it directly from a web browser on the same network and set things up. From what I can glean on the WD site you have to add someone to share and they get a url to follow to WD’s set up site and there they set up their account and in that process they get a username and pass to connect to the MyCloudHome.

You may have better luck on the WD forums asking assistance on setting up a new user.

Sorry but they’ve improved the MyCloudHome so much it’d be unusable for me.

Maybe someone who’s mastered the setting up of the MyCloudHome will see this thread and be able to shed some light.

I’ve tried Plex and everything works fine with that app, so I dont know. I’m not giving up because I think Infuse it’a the best app out there for this kind of stuff, I dont like Plex at all.

I’m also using Plex now and it’s working fine. But also not giving up on infuse as I think it’s way better.

1 Like

I got infuse to work with my wd mycloud home by using my admin user name and password. The same as you use to access the web interface. So email address as user. I had to leave the workgroup field blank.

I hope that works for you as well.


Already tried that way and still show me that just that public folder empty.

No error message?

Nope. It gave me the error message at the beginning when i wasn’t using user and psw.

That’s really odd… I don’t think I can help. I asked WD support as well. They suggested using guest as user and no password. Maybe try that. Otherwise out of ideas.

Via MacBook I access the WD via guest because if I use the user and psw that I use in MyCloudHome it won’t enter the time capsule forder.
How can I access the WD via Firecore using Guest? It always tell me to insert user or psw.

When it requests User and PW use Guest for user and leave the PW blank.

I managed to solve it !!! In infuse at apple TV write admin/admin in pass/name for adding source. All folder have in public and now i see that. Not error for push public.