Watched episodes / movies not showing as watched

I have a “catch all” folder that I use when downloading shows to my Windows 7 computer. This “catch all” folder is setup as a shared drive on the network and is connected to by the Apple TV 2 and Firecore’s Media Player app. It has worked flawlessly for the last year, and nothing has changed on either the “server” or the apple tv. 


A few days ago, the shows quit automatically removing themselves from the “catch all” folder via the “Not Viewed” tab of Media player. I can watch a show, and it will still show as not watched, with the little blue dot next to to it. I can even hold down and get the pop up menu, and say “mark as watched”. It will go away, but as soon as I go to another screen, like the “movies” screen, and then come back to my shortcut to the folder, they all reappear as not being watched. I also used to be able to delete episodes via the pop up command, and now its a grayed out option for me.


It’s quite frustrating to say the least. I have tried the following:

Rebooted the “server” computer

Went to the “mantaince” button for the Firecore app and told it to do a “restart” (safe for tethered) restart. 

I have just pulled the power cable from the apple tv and let it sit, doing a “power cycle” if you will.


None of those things seem to have fixed it. The network drives are NOT full, and appear to all be in good working conduction. The network is fast and responsive, no issues playing shows what so ever. MKV blu ray’s play just fine, but they don’t show as being played.


It almost appears as if there is a database issue? Or something like that. Maybe the database that holds the info of what’s been watched is locked somehow? 


I also tried to do a backup, its a no go… it fails immediately 


If anyone has had this issue and knows a fix, please let me know! Thank you in advance for your help!

I know it’s been 3 months, but I’ve had this problem intermittently.

It’s started again now, and who knows how long it will actually last this time.

This is one of the most frustrating bugs, and I’m really starting to wonder why I’m even using infuse over xbmc, besides just straight convenience.

I just started having this problem.  I have been using firecore since 2010.

I will watch en epsiode and it used to go to the watched list now it does not it stays with the blue ball as not watched.  I will even go and press the center button and force it to watched and it will go away then come right back so weird.  I wonder if I should try to reinstall, but don't think this will fix the problem.

I have apple tv 2 generation by the way.

I have the same problem recently in the last few weeks


Reinstalling fixed the problem, :)


I had this same issue and it looks to be down to disk space. - This helped me resolve the issue.