Washed out HDR colors thru Plex/Infuse on ATV4K'21

Hello,

Setup:

  • Apple TV 4K 2021
  • Hisense U7QF

The whole setup has been updated to the latest available versions as of today (OS, firmware, apps). HDR playback works flawlessly through Netflix and Apple TV+ – both HDR10 and Dolby Vision. Enhanced HDMI is enabled.

Picture appears severely washed out when direct playing (SMPTE ST 2094 App 4, Version 1, HDR10+ Profile B compatible) content through Plex. Somewhat less so, but still clearly washed out through Infuse 7 (via Plex). If I force transcoding the picture appears normal, but the signal changes and the TV switches out of HDR. SMPTE ST 2086, HDR10 compatible content appears normal when direct playing and the HDR signal is not lost.

I’ve followed the advice from this thread: Apple TV 4K 2021 and Infuse / HDR problem, but the solutions (switching to HDMI Enhanced and trying out different HDMI ports) have not solved the issue.

If I force Dolby Vision by disabling Match Content on Apple TV, the HDR signal appears to be retained when transcoding the picture in Plex, but I don’t know if this is accurate.

Any help would be much appreciated.

Peter

Would you be able to upload one of these videos so we can review it here?

UPDATE: The videos have been uploaded. It took less time than expected. Thanks.

Hi James. Thank you for replying. The files are quite large, and my upload speed is slow. Is there any other way for me to extract the info you need?

Today’s 7.3.4 update has a number of playback improvements, and many other improvements for HDR and Dolby Vision which may help here.

I would also double-check to ensure you have both of the Match Content options enabled on the Apple TV as this will allow for the most accurate picture.

Thank you for getting back to me.

Unfortunately, this update hasn’t resolved the issue for me. I’ve tried other solutions, incl. different players, to no avail. Some content works perfectly fine, and some just doesn’t, even when the video file specs appear identical.

I wasn’t able to replicate any issues like this with the samples you sent in.

As a quick test, can you try setting your video output to SDR and disabling the Match Content option for Dynamic Range? This will force the Apple TV to output SDR instead of HDR.

Just tried it again with no luck, image is still washed out. I’ve also tried the opposite – forcing Apple TV to output HDR or Dolby Vision – same thing. The only “solution” I’ve found is the one mentioned in the original post – to force the Plex player to transcode which, as I’m sure you’re aware, is no real solution, and frankly opens a whole other can of worms. Besides, I want to use Infuse and not jump back and forth between players.

Do you think it could be the cable? I’m using a cheap, but still 2.1-certified HDMI cable. It passes Apple TV’s built-in bandwidth test. Netflix and Apple TV+ work perfectly. I’m hesitant to invest a hundred bucks on the off-chance the issue might be the cable.

Hi there!

Out of curiosity: Would it be possible to post the media info from one file where you have problems with and from one file whichs works just fine?

Not sure if I can help out though.

First thing that crosses my mind when reading your initial post is that your file specs say HDR10+ somewhere. Your Hisense TV won’t be able to play back HDR10+.

BUT, from what I understand HDR10+ should have a HDR10 fallback which your TV on the other hand should be able to handle just fine…

Something doesn’t quite add up.

Btw/fwiw: I don’t think it’s a cable issue if it is truely HDMI 2.1 certified…

Well, so if you find the time, I am happy to look at ur media info results.

Cheers!