Want to enable AFP in ATV 2.2

Hi all,
Can anybody show me how to enable AFP in my ATV?, I have followed the instructions, and I get error 1069 -No servers at that address when I try to get the Mac, and from the Mac side I cannot mount the ATV and get Connection error message.
Thanks

From what I gathered from ATVflash, you cannot setup AFP shares on an Apple TV that did not originally have OS 1.0. You can possibly setup SMB sharing on later versions.

You can enable network shares by following the guide at:

http://wiki.atvflash.com/index.php?title=NitoTV_Smart_Installer

Basically, if your Apple TV originally came with:

1.0 software (most Apple TV’s purchased prior to October 2007) --> AFP + SMB

1.1 or later software --> SMB only

Where exactly is the documents folder? I can´t find it.
Is it possible that they have removed this folder on later versions of atv?
The documents folder should be Users/frontrow/documents right?
I have no such folder, what should I do?

The Documents folder is created during the aTV Flash setup. If you don’t have aTV Flash installed, the Documents folder will not be present.

Hi,

Thanks for your support, but unfortunately when I did it the ATV returned me an error while mounting.
I previously put made available SMB in the iMac and put the files available for guest users, but didn´t work
Trying to access from the iMac to the ATV via SMB shows error either.

Any suggestion?

By the way, I bought the ATv in June, so it should come with AFP. Shouldn´t it?

Thanks advanced

From elsewhere, but follow these instructions. You will need to change permissions on the relevant folders to copy the new files to them.

The files you need are here <edit - link removed> - [color=#BF0000]Please do not distribute these files here.[/color]

Okay, here goes, the files above are from a 1.0 dmg.

from sbin directory…

mount_afp

from System>Library>Filesystems…

Appleshare directory and its’ contents.

Please note - To enable write access of the root account, run the following…

sudo -S mount -uw /
sudo -S touch /.readwrite
sudo -S sync

Copy mount_afp to the sbin directory…

Copy Appleshare directory and its’ contents to System>Library>Filesystems

I did this with Cyber duck, but had to change folder permissions in Terminal then use Cyberduck?

Create a symbolic link from AppleShare/afpfs.kext to afpfs.fs in /System/Library/Filesystems on Apple TV, run the following command…

cd /System/Library/Filesystems
sudo ln -s AppleShare/afpfs.kext afpfs.fs

To then set owner and permissions, run the following…

sudo chmod -R 755 /System/Library/Filesystems/Appleshare
sudo chmod +x /sbin/mount_afp
sudo chown -R root:wheel /System/Library/Filesystems/AppleShare
sudo chown root:wheel /sbin/mount_afp
sudo chmod +s /System/Library/Filesystems/AppleShare/afpLoad

That works perfectly for me…