WAN is faster than my LAN?

Hello.
My setup :

  • Apple TV 4K plugged with ethernet cable
  • A router with HDD plugged in (around 980mbits reading speed) (I do use SMB for file sharing)

I only have 40mbps, which is clearly not enough fast.
I tried speedtest on my Apple TV 4K, and I got 500 mbps.

Why my local network is so slow ? (40mbps)
Before moving house, I don’t remember having this problem.

Thank you guys!

Speed network :

First thing I’d do is go to the share settings in Infuse and change from “Auto” to either SMB 2 or Legacy and see if that helps. Your router may be set to SMB 3 with a ton of security overhead.

The next thing I’d try would be to swap to a new Ethernet cable. Make sure it’s a CAT5E or better too.

I forgot to mention the fact that I’ve already tried to change for SMB1/2/3/Legacy, but I get the same speed.
My Ethernet Cable is a Cat7 :smile:

Did you try swapping it out?

No, but I get 480mbps on the Internet (which is the maximum that I can get), so I assume it has no problem.

Then you may want to try some of the other suggestions on the link above.

I’d still try a new Ethernet cable just to eliminate that for sure. I learned the hard way that assuming that since an Ethernet cable was passing traffic it had to be good. :wink:

When you use a router as a server there may be other settings in the router that affect local traffic.

Well, I just tried with CAT5E and CAT7, same speed. :pensive:

Which router (manufacturer / model) you are using? What kind of storage device do you use (HDD/SSD)?
Where do you have the storage connected?
Have you ever written a large file to the storage device from a PC and see if the same problem occurs? For me it looks like you have a problem with the USB Speed of the Router…

SFR Box 7. (USB 2.0, theorically 480 Mbit/s then)
WD Elements, USB 3.0. I used CrystalDiskMark and : Reading : 126mb/s Writing : 111mb/s

My storage is connected to the SFR Box 7.
I got no problem at all when I connect my HDD to my computer.

Please try to read/write to your WD via SMB from your computer and check which speed you get there (take a big file and copy it from your computer to the HDD and then back). So you can figure out if the problem ist the Apple TV or your LAN

image

HDD connected to my router.
CrystalDiskMark writing/reading through SMB on the HDD.

So the PC also has the performance problem when accessing the hard disk via SMB.

What can also be: do I assume correctly that the connected HDD is used with NTFS as file system? I suspect your router is running a Unix derivative system. This can read and write NTFS with certain drivers, but it is extremely slow. You can test another HDD and format it with ExFat or Fat32 and then test the speed again. Attention, Fat32 only supports files with a maximum size of 4 GB per file.

Local USB Speed (computer) (Fat32)

Local USB Speed through SMB (Fat32)

Infuse speed test : 28mbps

Edit : Added my network speed to the original post.

Mount the disk to your computer and create a share. Then mount it via SMB in Infuse on the Apple TV and do a speed test again.

Done.
image

Though, Infuse is not able to connect.

Yeah you have to create a share with the right rights.

Here you have an tutorial for windows 11 how to create a share without password protection. But remember to reverse the settings after the test!

https://www.elevenforum.com/t/turn-on-or-off-password-protected-sharing-in-windows-11.8076/

I only shared my hard drive, and it doesn’t require any password at all, so no idea why I can’t connect through Infuse.
I hate Windows files shareing :unamused:

Anyway, there is a problem with my router then.

Yes i think to that this problem have to do with a poor SMB or USB performance of your router….

1 Like