Wake up my mac

Hi :slight_smile:

I need your help because I am not able to wake up my mac in order to stream with Infuse.

You will find attached my configuration.

On my mac I ticked “wake for WI-FI network access” and my mac and the Apple TV are on the same network.

I though that the problem comes from the VPN but I tried to disable it and it still not working.

Do you think that the problem could come from my router ?

Thank you for your help :slight_smile:

PS : I am sorry for my english, I am french.

Are you streaming from your Mac via FTP/SFTP? We’ve seen a few cases where macOS doesn’t wake properly for these.

Thank you for your reply James, the protocol is SMB.

I’ve fought this demon for a while now and don’t have a lot to suggest but we’ll give it a go.

First, when you wake your mac from sleep (not just the display dark but the machine in the full sleep mode) look immediately at the upper right menu bar, does the wifi icon in the menu bar show grey then strobe from bottom to top as it looks for the network then locks on black bars?

Next, if you have an iOS device get a copy of an app called Fing. It’s a wifi net scanner. Use it to scan the net your mac is on and look at it both when it’s awake and asleep. If the mac info text is grey when it’s asleep and black when it’s awake it’s the same symptoms as mine.

It seems that for some reason when some macs are connected to the network by wifi only the radio goes to sleep with the rest of the system and that means no way to receive the wake on lan signal.

What OS is on the mac? What model mac?

The only work around on the machine I have that does what yours is doing is to connect it via Ethernet and then it’d wake on demand. It’s running OS 10.10.5. I have another iMac that’s on 10.12 and it works fine on wifi wake. Go figure.

Thank you very much for your time!

Yes it is exactly the case : when I wake up my mac he is searching a network !

During these days I tried an android app called Wake on Lan and it is working for 5 minutes but if I wait longer nothing. So I guess your theory is the good one.

Unfortunately I just have an Android but I think that we have our explanation now :slight_smile:

The mac is a macbook pro (2011) with sierra.

Indeed, yesterday I tried to connect it directly to the ISP’s modem/router with an ethernet cable and to connect the Apple Tv to the same network in WI-FI and it is working !!

Yesterday I ordered a switch because I have only one LAN port on my router I really hope that it will work (I am a bit afraid because the router comes from a small brand and there is a VPN on it). I choose to have no internet connection if the VPN is not connected but I guess that the local connections are not going through the VPN right ? I am really sorry but all these things are new for me.

One last think, for practical reasons I would like to keep my mac with the lid closed all the time, is there a risk ? I mean I think that it is not really great regarding the heat but it will only “work” when I need to stream a movie. In the energy saver settings I think that it is only possible to wake up the mac on Lan when it is plug in. Do you think that I can keep the mac plug in all the time ? The battery is almost dead but maybe it is better to remove it ?

Again, thank you very much for your help! :slight_smile:

The ethernet switch should not be an issue but I’m not a VPN guru in any way. I’d go with it to see anyway.

What OS version are you using and what model (and year) is your laptop?

A Macbook pro 2011 with Sierra :slight_smile:

This is an Apple page that discusses wake on lan and how to set it up and how to check if your computer will support wireless wake.

I’m not a fan of leaving a battery on charge for extended periods so if it’s possible I’d just leave the battery out and power supply plugged in. As to leaving the lid open, I’ve seen a few references to the effect that when closed it can’t wake on demand so since your leaving the power connected energy saving isn’t a major issue so leave the lid open and let it go to sleep that way.

Check as per this page to see if you’re mac supports wireless wake under the heading “Setting up Bonjour Sleep Proxy and Wake on Demand”

You may have to leave the ethernet connected to get where you want to be. I had to do it that way with my 2012 iMac. Why? Don’t know since it says it supports wireless wake but I guess mine is a deep sleeper.