Wake-on-LAN in Infuse 6 Pro for iPhone

Hello to everyone,

I am new to this community – I have just registered here. I have a question regarding the Wake-on-LAN feature in Infuse 6 Pro for iPhone.
The thing is that I have my home PC, which is on my local (home) Wi-Fi network, set up to be woken up by the Wake-on-LAN Magic Packet. So far, I have used one of the Wake-on-LAN apps available on the App Store for iPhone, which wakes up my completely shut down Wake-on-LAN-enabled PC. When it comes to this PC and Infuse 6 Pro on my iPhone XS Max, running on iOS 14.0.1, the PC is set up as a local share, using the SMB protocol.
Now, so far I have used Infuse with the PC already turned on to stream videos on my PC to Infuse. However, today I wanted to open Infuse with my PC shut down to simply stream some videos I had uploaded to my Apple iCloud Drive earlier. To my surprise, once I opened Infuse with the PC shut down, the PC booted up. Once that happened, I instantly realized there must be some connection between opening the Infuse app on the iPhone and the PC booting up. Looking around, I found out in this community thread Does Infuse support WOL feature for waking PCs up remotely? that just as once the Wake-on-LAN feature was available in Infuse, later it was not possible to implement it anymore due to some changes to iOS. However, as I can see the case being with Infuse 6 Pro now, Wake-on-LAN is available in it again. Now, just as it is available again, my problem with it is that I don’t want it. When I don’t use my PC, I want to able to stream videos from my Apple iCloud Drive or some other online drive only, without booting up my PC through Wake-on-LAN. I have tried to look for the Wake-on-LAN setting in the Infuse Settings, but to yet another surprise of mine, I cannot find any Wake-on-LAN setting, be it in whichever of the categories of settings under the Settings section in Infuse, or under the settings for the local share added to Infuse.
The situation being as is, my question is: Is there a way to turn the Wake-on-LAN feature in Infuse off, so that it does not boot up a shut down PC on a local network when I don’t want it to boot it up?

Thank you for your help in advance,
Best Regards

Welcome to the forum!

The way I understand it Infuse has to touch the LAN to work. When it launches Infuse looks for the shares that are attached so it can check for updates. If your PC is off then I’d say there are some settings in the OS of your PC that may be the reason. Have you tried turning off WOL in the PC?

There’s an article mentioned in one of the posts here

that tells how to turn on WOL so maybe if you do the opposite and turn off WOL you’d not have the computer turning on when not wanted.

Thank you for your reply.

Yes, you are right that I have the Wake-on-LAN function enabled on my PC, obviously at the system BIOS and network adapter level, as otherwise the PC would not boot up from the Magic Packet trigger the way it does. The thing is that I cannot turn the Wake-on-LAN function on the PC off, since I need to be able to boot it up remotely (normally I simply boot the PC up using an app dedicated for it and operate it remotely, i.e. over my home Wi-Fi network, for convenience reasons, since being a disabled person, I want to do what possible so that I don’t need to get up to the PC, but boot it up and operate it from my bed). Therefore, the situation being as is, I cannot turn the Wake-on-LAN function on my PC off. The only thing I wanted to find out in my case in particular was, as if in relation to Infuse “touching the LAN to work” that you mentioned, whether or not it is possible to prevent Infuse 6 Pro from booting the PC up on launch?

Thank you in advance,

Best Regards

I don’t use Wake-on-LAN, so this suggestion may or may not work.

I believe in the SMB connection in the Advanced section the MAC address field was added to allow WOL packets to be sent to that address.

Maybe if you put a dummy value in there the WOL packets will be sent to a non-existent system. The problem is that Infuse might use it for the normal SMB connection and prevent it connecting normally. But might be worth trying.

2 Likes

You solved my issue 100%, remotevisitor. Earlier, I had been using Infuse 5 Pro (which is the predecessor of Infuse 6 Pro), so that when I saw that there is a field for a MAC address of the SMB NAS (if you can call it a NAS) in Infuse 6 Pro, I concluded that it would be a good idea to add the MAC address of my PC, so that Infuse 6 Pro would find it on the local network and connect to it for sure. I didn’t think that having the MAC address of the NAS added, Infuse would force WOL just because of this MAC address being added. Removing that MAC address from the NAS settings, Infuse 6 Pro still finds and connects to my PC on the local network, playing videos from the PC no problem :slight_smile:

Thank you a grand for solving my issue :slight_smile:

Best Regards

Great idea! Thanks for the help! :+1: