Wake on lan improvement

Hi there,

It would be cool if the wake on lan command could solely wake up the device whose share I want to access in infuse.

For example, if I access a video file that is stored on my nas, Infuse should solely wake up my nas and not my pc as well. At the moment, Infuse wakes up all connected devices which renders the WOL feature useless for me.


WOL uses a MAC address for your NAS. not sure how your computer would wake up too unless the NAS is connected directly or waking it up on its own. Do you have any idea?

In Infuse while having the MAC address entered speeds up the wake it’s not necessary to wake a device. It will still wake the share by name and or address it just takes longer.

If the OP has a share specified in Infuse that resides on their computer then Infuse will also wake it to check for updates.

From what I remember, WOL only works if the device is in shutdown, but if it is sleeping/hibernating that doesn’t make a difference and will wake up as normal. Maybe it depends on the NAS , but I think that’s how mine works.

Nope, I have a test share on a computer that is set to sleep and Infuse will wake it on start up of Infuse even though the MAC address isn’t set. It just takes a few minutes longer.

Okay then it must be device specific. My Synology NAS only recognizes the magic WOL packet when in shutdown. It will immediately wake from sleep when infuse requests data without it.

The only way everything would wake up at the same time is if you had things connected to a hub instead of a switch.

Thanks for the feedback. If I’m the only one whose storage devices wake up at the same time when accessing a share, something might be wrong with my wol settings. I’ll check this.