Waiting for Apple TV 2!!!

Tried all the required procedures but still getting stuck at the same point, waiting for apple tv2 while trying to dump shsh using iFaith either after exploitation or after uploading iBEC. Most of the time it does after uploading iBEC.

My ATV2 is currently on 5.2 without any saved blobs. Just trying to extract the blob locally and trying to cook the firmware using snowbreeze.

Any help is greatly appreciated.


sameshit here! can someone help?

This seems device specific. I have one 5.20 behaved like this and others just worked fine.

I was having this same exact problem on all my laptops.  It didn’t matter if I was using XP, Vista, or Win 7 on these laptops.  Each time it would already get stuck after the exploitation stage then if i pressed the 2 buttons together it would maybe goto the next thing on the list.  But no matter what, it would always get stuck on upload to ibec.  It also didn’t matter if i had the power cord plugged into the apple tv device either, and didn’t matter if I had iTunes launched or not.

Then I tried iFaith dump on a windows desktop system with XP and it has worked everytime I try to do the dump!!  Have been successful on at least 3 devices now!!  And I do not need the power cord plugged into the outlet and also did not need iTunes launched either.  It went straight to saving and asking me where to save the file to.

I think it was something to do with laptops not having enough power to the USB port to allow it to complete the dump process.  

Try using a pc desktop and let us know if it works for you!

I am using a desktop and still getting stuck

OK, first thing you should do is to run TinyUmbrella to kick the ATV2 out of recovery mode in case it has got stuck.

Next, make sure you are running iFaith with iTunes also RUNNING.

Don’t ask me why, it just works.

iFaith sometimes crashes while saving to icj.me in which case you’ll have to do it again if you want your blobs safely stored on Cydia.



When i run timnyumbrella my apple tv does not even show up as a conected device


1- use the latest ifaith 1.5.8 

2-  use iREB-r5  put your apple tv on dfu mode .  then open ifaith and fallow the steps and it will take it . 

But the first thing you do when you open iFaith is to put the ATV into DFU mode.  You don’t want to do it twice.


Can i use iREB-R7 off of the sn0wbreeze sight or does it specifically have to be R5. Also i am on 5.2.1 if that makes any difference.


Thanks in advance

Ok so I have tried iREB-r5 iREB-r7 and iREB in iFaith. It stops on waiting for apple tv 2 after exploitation. If I press and hold Menu and pause for 7 Sec it will the upload iBSS and upload iBEC but then stops after upload iBEC and says waiting for apple tv 2. No matter what i try it will not go past there.

Here is the fix on a Windows machine and it should work right away:


Right click on your iFaith icon on your desktop, go down to properties at the bottom and left click, click on the compatability tab at the top, then select "run this program in compatability mode and select “windows xp service pack 2”, then go down and select run this program as the administator at the bottom. Then click apply and then OK.


Then run iFaith and dump your blobs let iTunes run in the back ground don’t stop it. If you get your timing on the prompts correct it will dump your blobs just fine.

I bet it works on the first or second try for you all having issues. I was getting extremely frustrated as well but finally got it to work almost everytime using these tweaks!

Good luck!












I the same response. Stops at EXPLOITATION, I have to press and hold Menu and Pause, then stops on iBEC again and just says waiting. For some reason i now got the message above ater iBEC it said communicating with apple tv and then this popped up. Any ideas?


This is where it Stops


Change the USB Change yo a different version of ifaith.

i am having the exact same problem too :frowning: appletv2 running 5.2 without any saved blobs. trying to extract the blobs using iFaith but it is getting stuck at the exploitation or upload iBec stages. i have tried running it as administrator/etc as has been suggested but it does not make a difference. i am tearing my hair out!! not sure what else to try!

Try experimenting with different versions of iFaith.  Some versions work better than others.   Sometimes it takes several tries for the ATV2 to enter into DFU mode at the pricise time for the software to read it.  Also, try more than one usb cable.  There have been countless times people here have claimed there is nothing wrong with their usb cable only to post weeks later that the problem turned out to be their usb cable…sigh.   I had one ATV2 that required me to plug the usb and the power cord in while running iFaith so might want to try that too.

I know it sounds silly but try it with iTunes open at the same time as iFaith.

Trust me, it works.  i use iFaith 1.5.9 and an old 10.6 iTunes.  Dumps blobs second time every time.

you guys are making this process complicated season pass came out with a version so easy even a caveman can do it.


Just plug the unit in open season pass beta, right click create ipsw go down to 5.2 and just follow the instuctions and it will do the rest forget about snowbreeze

That will only work if there are blobs for 5.2, right?  Without blobs, will this procedure work?

correct. no.