Video stuttering


I am suffering from video stuttering for some of my 720p files which were downloaded from YouTube.

Welcome to the forum!

Device? ATV4, ATV4K etc
os version?
Infuse full version number?
Pro, subscription to Pro, free?
Type of share connect? SMB, DLNA, Plex share?
Wired Ethernet or WiFi?
Type of file? AVI, MOV, mp4, MKV, etc?

Device? ATV4K
os version? 13.3.1
Infuse full version number? I have 2 versions: 6.2.6 (2900) and 6.2.5 (2888)
Pro, subscription to Pro, free? Pro
Type of share connect? SMB, DLNA, Plex share? SMB
Wired Ethernet or WiFi? Wifi
Type of file? AVI, MOV, mp4, MKV, etc? mp4

Have you done a network speed test on the file that is giving you problems?

I did several network test including this file and others. The wifi speed is more than 30mbps. Furthermore, in have tested 4K videos and the worked fine; so it is not a network issue.

Is that speed for that specific file? If so, what kind of speeds are you getting for 1080p files and your 4K files?

What compression codec is being used on the file?

Just as a comparison when I do a speed test on a 720p mp4 file I have I get 95.92 Mbps average with a minimum of 89.29 Mbps. It plays without stutter.

MPEG-4 (Base Media): 164 MiB, 27mn 16s
1 Video stream: AVC
1 Audio stream: AAC LC
Duration: 27mn 16s
Overall bit rate mode: Variable
Overall bit rate: 842 Kbps
The details of the file is in the attached picture. By the way, the files name includes arabic characters. I am assuming that would not be causing any problem.

Regarding the speediest, the difference in the speed with different file size is not big ±2mbps…

Have you tried changing the SMB protocol from Auto to either “2” or Legacy? sometimes SMB 3 overhead can cause stuttering and some devices prefer either 2 or Legacy.

Is AVC acceleration supported through hardware or is it all rendered in software? That might be the issue. I’d test in another player such as VLC. If you run into the same problem there then it’s an issue with the file.

I have done further testing:
1- Connect the ATV directly to the router using ethernet port and I got the same problem
2- Use FTP instead of SMB; also the same results
3- I checked the router (WRT) and I could not find any option to change the SMB type
4- from 1 & 2; it is clearly not a network issue
5- I used VLC and the video played smoothly
6- Tried Infuse on iPhone 10 and still the video was stuttering.

Finally, I have shared the video that I am using for testing so you can test:
(link removed)

Wasn’t referring to your router to change the SMB levels that’s an option in Infuse to help match to your router. It’s in the Infuse Settings > Shares > Select share > Edit Share > Advanced > SMB Version > Try SMB2 then test and if that doesn’t help try “Legacy”

[Deleted original incorrect info]

Edit to add: Now I’m not sure. Just tried it in VLC and not a problem. Maybe James will be able to point out the blatanly obvious that I’m missing but your right it’s strange.

Thanks for the sample. We’ll take a look.

Hi James,

Did u have chance to look at this issue?