Video skips a second back, then subtitles are out of sync!

Fix this, it is extremely annoying, and you have to stop playback, and resume, so that it will play in sync (airplaying to Apple TV). It happens on many movies and episodes, on both iPad Pro (2018) and iPhone 13 Pro, both updated with latest OS
Screengrab of the properties of latest video in which it happened.

1 Like

What version number of Infuse?

Which ATV? What tvOS version number?

Apple TV 4K (2nd gen) on tvOS 16.3, and has also happened on Apple TV 4K (1st gen) on tvOS 16.2 (not used since 16.3 update).

Does this happen with other videos or just this one so far?

Many. Over the past several months. This is the first one I made a note of.

Would find it very strange that it is only happening to me.

Are the subtitles becoming out of sync after you manually skip back, or are the videos skipping on their own?

Did you create all the videos with this issue yourself?

Describing the exact steps you take prior to encountering the issue will help others identify if they have experienced the same; and help a different set of users replicate and possibly confirm any possible bugs in tvOS and/or Infuse being the cause.

A better breakdown of video file encoding details (for diagnostic purposes and highlighting commonalities in glitching files) can be generated with the application MediaInfo.

If the issue can’t be easily replicated by others, but @james wishes to pursue it, he usually requests you generate a diagnostic code and upload a sample of troublesome files to his Dropbox, so you may want to start preparing to do that.

No, nothing about this issue is manual. Maybe “skip back” is not the right wording. It just repeats a second, it just does it, randomly, I don’t press any buttons or do anything.

Also, I didn’t “do” these videos, they are widely available torrent video files of popular TV shows and movies.

I will download that MediaInfo application and provide info if requested.

1 Like

What version number of Infuse are you using?

Latest, always the latest available. 7.4.10 (4329)

Just curious, why airplay to ATV instead of playing via Infuse on the ATV?

Also, if you’re just playing on the iPhone or iPad (not airplaying to TV) does it still do the skips?

1 Like

Because my video files are stored on my mobile devices, so that I always have them with me, not just to watch at home.

The skipping seems to only happen when airplaying, not when watching on device.

Do you have background app refresh turned on in the iPhone and iPad settings? If so I’d try turning it off at least when you’re using airplay.

It is off on both devices.

Have you tried airplaying with other apps to the ATV? It sounds like something is causing Infuse to hesitate.

Maybe try changing the streaming cache from auto to memory only and then Legacy if that doesn’t work.

I have not tried other apps, I am paying a lot for this one, which is why I am using it.

The streaming cache doesn’t make a difference, it happens on all options.

Just a suggestion to help troubleshoot the problem. I didn’t mean to switch permanently to a different application. It may be related to airplay and trying it with another app would give some clue as to where to look further.

Perhaps I should be looking for an alternative app. There has been 0 interest from that James or anyone at Firecore. Obviously not important, but I will not continue paying a yearly subscription for this buggy app.

Are these subtitles embedded within the video file, are they your own external subtitles, or subtitles downloaded from within Infuse? Does switching to a different type of subtitles make a difference?

I don’t recall seeing other similar reports, so I’m not sure if this is file-specific or perhaps something related to your setup.

Any combination. I have been making a note of all the movies and series it’s been happening; embedded, added by me, the ones that come with the video file (srt, sub), added via the app… I don’t think it’s the subtitles that’s the problem, it’s the video, it repeats a second (approximately), hence the subtitles are no longer in sync.

Thanks for all the help!

By “my setup”, what do you mean exactly? That use an iPad and iPhone, that they are connected to wifi… how would “my setup” be different to other’s who don’t seem to have this problem?