Video playback issue on 2022 ATV4K

Hello everyone,
i’m having some difficulties playing a BD rip located in my NAS from my Apple TV 4k 2002. At the moment it seems that is the only one i’m having issue.Audio plays fine and also subtitles are shown, but video is always black). File can be played with VLC but i think i’m not getting Dolby Vision looking at the image brightness. I post down here the mediainfo, someone could help me point out what is causing problems (i tough it was bit depth but it is 10bit so should work).
Thank you

ID/String : 1
OriginalSourceMedium_ID/String : 4117 (0x1015)
Format/String : HEVC
Format/Info : High Efficiency Video Coding
Format_Profile : Main 10@L5.1@High
HDR_Format/String : Dolby Vision, Version 1.0, dvhe.08.06, BL+RPU, Blu-ray compatible / SMPTE ST 2086, HDR10 compatible
Duration/String : 2o 35min
BitRate/String : 59,7 Mbps
Width/String : 3.840 pixel
Height/String : 2.160 pixel
DisplayAspectRatio/String : 16:9
FrameRate_Mode/String : Costante
FrameRate/String : 23,976 (24000/1001) fps
ColorSpace : YUV
ChromaSubsampling/String : 4:2:0 (Type 2)
BitDepth/String : 10 bit
Bits-(Pixel*Frame) : 0.300
StreamSize/String : 64,8 GiB (96%)
Language/String : Inglese
Default/String : No
Forced/String : No
colour_range : Limited
colour_primaries : BT.2020
transfer_characteristics : PQ
matrix_coefficients : BT.2020 non-constant
MasteringDisplay_ColorPrimaries : Display P3
MasteringDisplay_Luminance : min: 0.0050 cd/m2, max: 4000 cd/m2
MaxCLL : 787 cd/m2
MaxFALL : 239 cd/m2
Supporto originale : Blu-ray

What version of tvOS and infuse are you running? Does it work on iOS/macOS?

Current status of Dolby vision on tvOS

6 posts were split to a new topic: Video output issues/observations with 2022 ATV 4K

There was a similar issue which was addressed in 7.4.9, so if you are seeing issues with DoVi files when using 7.4.9+ then we would love to get more info.

2 posts were merged into an existing topic: Video output issues/observations with 2022 ATV 4K

I had similar problems with the 2022 model. Simply, the 2022 model does not know the extended HDMI mode (or something similar), more precisely sometimes it works, sometimes not, the 4K SDR 60Hz/444 does not work properly, if it does work and I try to play a Dolby Vision material, it will be black the picture and then it can’t change it back. It’s as if the cable is at fault, but it’s not, because the Apple TV 2021 is flawless, I don’t have such a problem.
For example, there is a material that was recorded with an iPhone (glass blowing), it is flawless on the 2021 model, on the 2022 it goes in HDR10, 10 bit 420, which would not be a problem, but because it is actually Dolby Vision, if for some reason it switch to Dolby Vision, then there is no picture.

I can’t provide more information, it doesn’t work properly on the 2022 model, it’s flawless on the 2021. Therefore, I would rather suspect an OS or hardware problem. I don’t think that is an Infuse issue, the playback is also incorrect in the case of other apps.

Which version of Infuse are you using?

Would you be able to send in a sample of one of the affected files we could review here?

Always the latest, current version, now 7.4.10, it was the same with 7.4.9. It doesn’t matter what the material is, the 2022 model has problems with all of them, so I’m already using the 2021 model, it’s perfect. This is why I’m writing that I don’t think Infuse is the fault. It’s also possible that the 2022 model doesn’t like my TV (Philips OLED). The picture is simply wrong, and banding is noticeable in HDR mode compared to the previous model. link
In summary, Infuse works flawlessly on the 2021 model.

The original issue posted here is related to a black screen when playing certain files. It sounds like this may be different than what you are seeing.

You may try adjusting the Chroma option in the Apple TV video settings. 4:2:0 will be 10-bit, and 4:2:2 is 12-bit. Your Philips TV may like one but not the other.

The consequence of what was described in the first post is what I experienced during my tests, so the display is problematic with the 2022 model.

In general, on the 2022 model, cannot select 4K SDR 60 Hz YCbCr 444, 4K 60 Hz full RGB, the image will be black. 4K SDR 60Hz YCbCr 420 is perfect, but in this case some Dolby Vision material starts in HDR10. (I know, it’s as if the cable is bad or the TV isn’t capable of it, but that’s out of the question, because everything works with all my other players and, as I wrote, it’s flawless with the 2021 model as well, I tested it for days, changed cables and inputs)

It happens that for some reason 4K SDR 60Hz YCbCr 444 can be selected from the menu, but then the image becomes black in the case of some Dolby Vision materials, just like in the first comment and this is not only the case with Infuse.

On the 2021 model, all formats can be selected and everything works perfectly, so the TV and the player work well, the cables are also good, there is 4K SDR 60Hz YCbCr 444, there is 4K 60Hz full RGB.

Because of the above, I sold the 2022 model and I am using the 2021 again, I do not experience any errors with any HDR format.

At the moment I have no problem with the 2021 model, I just wrote that I experienced the same with the ATV 2022.

In general, on the 2022 model, cannot select 4K SDR 60 Hz YCbCr 444, 4K 60 Hz full RGB, the image will be black.

I’m sorry @aceman but that’s not my problem. I attach a photo of my TV running 4K SDR 60 Hz YCbCr 444. My problem is that the “video layer” is black, subtitles and GUI is shown and responsive, also sound is ok.

What version of tvOS and infuse are you running? Does it work on iOS/macOS?

Infuse Pro 7.4.10 (4329) / tvOS 16.2 (20K362)

If there is something i can do within the next few days for debug this please let me know. Today i did more testing with the ATV and, i really like a lot of thing about it, but i’ve tested also the Shield Pro and it suits more my usage (less streaming, more NAS content with Atmos & Vision). For that reason i’m returing the ATV in few days and get a Shield Pro.

I know you said this isn’t specific to Infuse, but I’m not able to replicate any of this here with a 2022 ATV4K and a Samsung QN90A.

If you have dynamic range matching enabled in Infuse, then the default video settings won’t necessarily apply (EG SDR settings do not affect HDR or DoVi output), and it’s normal for some DoVi samples to play with HDR output (if they are a profile not natively supported by the Apple TV).

Aside from that, I can’t really explain what you are seeing here, but I’m guessing this may be related to the specific combination of Apple TV model, HDMI cable, and TV model/settings.

If you’re able to send in a sample of one of the affected files we’d love to take a look.

You don’t get it but it’s simple, select YCbCr 420 and then play the problematic file, you’ll see the picture, at least it’s not black.
I just deduced that there was a problem with the 2022 model.

I know it’s not simple, but something is wrong with the new model, I don’t know what. I had more than 100 players, tried everything possible, playback is problematic with the new model in my setup, tested with similar files, cables and TV, only changed the players, tried with 5 players, ATV 2021 (2 devices), ATV 2022, Sony X700, buzzTV X5 + CoreELEC , only on ATV 2022 the playback was faulty. After that, I also performed a test where I changed the cables, it was the same, the errors always appeared with the 2022 model, it could be software, it could be hardware issue, but that didn’t help me, the only solution was to change back to ATV 2021.

I don’t want to derail what James is developing but is it possible that you have a faulty 2022 ATV 4K? If you’re not seeing the issue on all of the other devices and it’s only happening on the one unit coupled with James not being able to duplicate it with his 2022 ATV 4Ks then maybe you got a unit with a problem.


It could happen, but I would guess that some kind of modification was made in the case of the new model, which can no longer switch to the correct format in all cases (my TV supports all HDR formats), by the way, someone else tested it, with another device, the display is weaker compared to the previous model (previously linked), it turns black in the same way in the case of Dolby Vision, there is no image, then it cannot switch back to the set format, you have to force it with a key combination.

Just remember (if you care) shield does not support framerate matching. Some people hate that, others less so. Shield + Plex is certainly a powerful solution for local MKV playback. I wish infuse was available for shield as the AppleTV has some hardware / os limitations when it comes to sound.

Right observation but Kodi has framerate matching so no problems with my local files. Hope to see some development of infuse for Android platform too, but i think all the pros comes from Apple platform. Unfortunately Apple is not implementing some function and we can do nothing about it other than using what does almost all the thing we need and,in my case, nvidia is missing only framerate matching on streaming service. Consider howerver that it is in beta and maybe someday we’ll get it also on all apps.