Vidéo buffering and audio loss for high bitrate videos

Hi.
Infuse buffers when playing high nitrate videos (close to 100Mb/s) although the network is more than fast enough to cache files at a much higher bitrate.
That is on both Apple TV and iPad.
In both cases, the connection speed to the internet is more than 100Mb/s as said by the Speedtest app.
And a 90Mb/s 6 minute video copies in under 2 minutes from my NAS to my iPad using the Files app.
It stops after a while when playing from the NAS in Infuse on my iPad. It start again after some time, but with no sound. If I pause and play the video again, the sound plays again.

As for protocols, I use NFS to access my NAS in Infuse (which used to be the most reliable protocol for that) and SMB in the Files app.

Diagnostic code (iPad) 0NDAX

Have a look in settings, and change the cache method to legacy mode, then if that does not work, try the other method.

You can also run a speed test from with Infuse.

This will test the actual speeds you are able to get when streaming from the source where the videos are stored, which may be different than the speeds you see in the Speedtest app. The speed test option in Infuse can be found when viewing the settings for the saved share.

Thank you both for your answers.

@stimpy88 I changed the cache setting to legacy on my Apple TV 4K 2021 and iPad Pro 12.9" 2020 and I do not seem to experience the buffering issue anymore. Thanks! :slight_smile:

@james the audio should come back when buffering is finished and the video starts playing again - it seems to me it is a bug.
Regarding speed tests, the one inside Infuse seems very inaccurate:

  • on my Apple TV 4K it shows 103Mbps (using the same file of course and the same NFS share),
  • on my iPad it shows between 20Mbps and 40Mbps - it that was the actual speed, it would need at least 14 minutes to play this 6 minute file, which plays without buffering (now with the legacy cache mode) or with a little buffering.

Furthermore, the download in Infuse on my iPad of the same file takes 2’29", which is about 200Mb/s (the download of the same file in Infuse over SMB takes about the same time but has to be restarted several times in order to complete. - I tried with SMB mode to auto, SMB3 and SMB2)
And the download with the Files app over SMB takes 1’14", which is over 400Mb/s.

1 Like

Turns out it’s Infuse over WiFi (on Apple TV 4K 2021) that does not work well.
Over Wifi : speed test in Infuse ca.30 Mbps, 100Mbps movie freezes after 5s.
Over ethernet …connected to an external wifi adpater: speed test in Infuse 140Mbps, 100Mbps movie plays without issue.

Speed test in the Speedtest app is ca.400Mbps over WiFi and 500Mbps using ethernet and the external wifi adaptor.

So I will have to use an external wifi adopter for my Apple TV, but no solution to play my big 100Mbps files on my iPad (I do not want to use an adapter) …I cannot even play a 100Mbps on my MacBook Pro, which has a 1300Mbps wifi connection, and on which I can copy the same movie from my NAS at 400Mb/s!!

Apple TV diagnostic code: 2P2DB

Note: this is using tvOS 15.1 RC 1 and Monterey RC 1

Heres some more info on the speed test. But sounds like you need to fix your WiFi connection. https://community.firecore.com/t/infuse-6-2-4-2875-rc-2/18938/21?u=munpip214

Thx but, on iPad, or on the Mac, the wifi is plenty fast enough to download the file at 4 times the required speed to play it or more. Out of Infuse (in the Files app or the Finder for example). Only in Infuse is it too slow.

So I do not think I need fixing my wifi. The wifi speed issue is limited to Infuse.

That’s fairly high bitrate. 4K? I haven’t seen anyone have good luck streaming 4K over WiFi. Not saying it is impossible but challenging. Downloading movies isn’t the same as streaming as that post I referenced mentioned.

That’s fairly high bitrate. 4K? I haven’t seen anyone have good luck streaming 4K over WiFi. Not saying it is impossible but challenging. Downloading movies isn’t the same as streaming as that post I referenced mentioned.

Thèse are re-graded 4K HDR videos, compressed as little as possible, so to 100 Mbps, which is the maximum for 4K blu-rays.

100Mbps is far less than my WiFi can handle, and the files play fine when stored locally on my iPad. They should work over wifi.
The Mac is a good place to test things. So on my 2018 13" MacBook Pro - to be retired next Tuesday :slight_smile: - , connected via WiFi to my home network, the same 100Mbps video file:

  • gets copied at 4x speed in the Finder,
  • plays without any buffering in VLC,
  • plays without any buffering in IINA,
  • plays without any buffering in Infuse if opened from the Finder using “open with”,
  • stops playing after 5s in order to buffer video in Infuse (played normally from the library or the “Files” section)

With my MBP connected via Ethernet to a Wifi adapter, itself connected to the same wifi network as before, the same video file plays without buffering in Infuse from the library or the Files section.

So I do think that there is an issue in how Infuse handles network connections over wifi, which only manifests for large bitrate videos.
It’s good to have a Mac version to be able to analyze it. :slight_smile:

Have a great day all.