Vertically squished aspect (short & fat) in 0.60, not 0.57

Hello,
I’m getting a very vertically squished aspect ratio (everyone very short & fat) in 0.60. Here is my setup (and additional comments/thoughts in brackets):

ATV Take 2, upgraded to 2.2
ATV Flash 3.3.4 via the Apple Core patchstick
VIDEO_TS folders ripped movie only by MTR 3.0r14m
—(they play fine on my MacBook)
Playback via NitoTV 0.60 & DVDPlayback.framework
—(because I get no on screen feedback when I press the remote buttons so that means DVDPlayback.framework, right?)
Smart Installer has been applied
Perian 1.1.2 is installed
ATV set to output at 1080i
—(When I try 720p I get sound but blank (black screen) in NitoTV (only))
—(Component cables–my TV/stereo do not have HDMI capability)
My TV is 16:9 NTSC and capable of up to 1080i but not p
File Playback Mode set to QuickTime/mPlayer/Mixed does not change anything
—(Which it shouldn’t cause I’m playing back via DVDPlayback.framework right?)
MPlayer arguments for -aspect, -monitoraspect set at 16:9, 19:13 etc don’t change anything
—(Again, which it shouldn’t cause I’m playing back via DVDPlayback.framework right?)

I have about 200 movies ripped from DVD on my USB drive, I think all but two of them played with the correct aspect ratio when I was using ATV Flash 3.3.2/NitoTV 0.57. They all (including the two exceptions) played with the correct aspect ratio on my MacBook. Now that I have upgraded everyone is short & fat on my ATV. My quicktime HD movie trailers downloaded from apple.com and other content streamed from the iTunes store play fine.

For what it’s worth, I do NOT get the white dot that edmartin mentioned in his earlier posts referring to 0.56.

Any suggestions? This is otherwise a great product, worth the price even without CouchSurfer/Jamon/etc… For now I think I will try downgrading to 3.3.3, and if necessary back to 3.3.2.

Thanks Nito!

Hi there!
I talked (in a forum kind of way, so did edmartin on the same issue) with nito about that. He´s on it.

quicktime/mixed/mplayer affects only file playback
dvd playback is set to framework by running the smart installer. from that point, the arguments don´t matter (for dvd playback)

workarounds:

  1. go back to 0.5.7 (obviously :slight_smile: )
  2. for you hdmi-people: switch to 720p since this issue is known to be 1080i only
  3. re-run the patchstick but don´t run the smart installer. usb should work (because it worked before) but the dvd framework isn´t activated. you should be able to view dvds via mplayer (theoratically)

cheers
winmannn

I’m happy & I’m sad that someone else is seeing the same thing. I had it in 0.5.7, too, though.

Not trying to send people to another forum but Nito is pretty active over in the AwkwardTV forums. Here’s the link to the thread where he & I have been talking:

http://forum.awkwardtv.org/viewtopic.php?f=6&t=2061

Winmann and edmartin–thanks for your comments…

  1. Is there still a link to 0.57 as a stand alone zip somewhere? The one I found in (?)AwkwardTV forums points to 0.60 now.
  2. Interesting that this problem manifests in 1080i only and not 720p, I must have missed that thread. As I mentioned before, 720p for some reason gives me a black (blank) screen with sound when in NitoTV although it works fine for everything else.
  3. I tried re-runing the patchstick without smart installer, but then when I try to run the video_ts it seems to hang and I get a blank/black screen, not even sound, nothing.

I’ve now tried rolling back to the briefly available ATV Flash 3.3.3, and also ATV Flash 3.3.2 (which did work for me) but the app calls home and if I deny it in Little Snitch I can’t install because “no internet connection”; if I allow it I can’t install because “out of date, download latest version from website”. Still waiting to hear a reply to this in the flash drive creation forum.

Could it be a problem with the version of DVDPlayback.framework included with 3.3.4? Where does this file come? Is it from the macosx10.4.9comboupdater? Somewhere else? Does it make sense to try and replace this one file only? If so, someone please send me links to older or newer versions of this file and where to put it (I have cyberduck), and I will post my results back to this forum.

Thanks to those who replied and those who took the time to read the posts…

Hi!
Can you be more specific on

the app calls home and if I deny it in Little Snitch I can’t install because “no internet connection”; if I allow it I can’t install because “out of date, download latest version from website”.

Do you mean the program that creates the patchstick?

Couldn´t get my hand on 0.5.7, too. So I made a patchstick with 3.3.3 (which worked flawlessly) and used it on a fresh restored atv (1.1) after update to 2.2 (wanted to be sure). 3.3.3 contains 0.5.7

Maybe you could ask nito himself for a download link.

720p (hdmi) was trial and error on my side, just passed the info to nito.

cheers
W

ps:
md5 of my comboupdater: 2c579f52ad69d12d95ea82ee3d9c4937

Yes–the program that creates the patchstick. I have the disk images for 3.3.2 (last working version for me), 3.3.3 (never got to try it), and 3.3.4. The problem is the patchstick creator app calls home and will only let me install the latest (3.3.4) version. How were you able to get around this to install 3.3.3? Now let’s assume for a moment I’m eventually able to create a patchstick with the older 3.3.2/3.3.3 versions; can I install it just like normal, or do I have to do a “factory restore” first? (want to avoid this since it will take hours to x-fer my iTunes database.

And now things get stranger and stranger…I’ve tried changing resolutions again: 1080i, 720p, 720p@50Hz and here’s what I found:
[list]1080i: Seems like all movies play, but with the squished aspect ratio I started this thread with. (and first 10 seconds is sound but no picture, after this A/V sync is fine).
720p: Some (but not all) movies play fine with correct aspect ratio (after the 10 seconds mentioned above). The rest play sound only, no picture ever comes up, just a black screen.
720p@50Hz: Now different movies play fine with correct aspect, and some that worked at plain 720p (above) now give me sound but no picture.[/list:u]
A few movies will play with correct aspect in both 720p and 720p@50Hz. I live in north america, thus the standard here is NTSC 60Hz. My TV does not support 1080p nor 1080i@50Hz.

Still hoping to downgrade my patchstick to ATVF 3.3.2 or 3.3.3 with NitoTV 0.57…will update the forum with my results if I am able to do this. Thanks to all who replied.

Thanks, my MD5 matches yours.

Hi there!
I guess I found out why I was able to create the 3.3.3 patchstick. Version 0.6 was installed by hand not via a patchstick. After it failed to work properly I made the 3.3.3 patchstick prior to the release of 3.3.4. That´s my only explanation. I don´t want to test it because I have got only this usb-stick and I don´t want to lose 0.5.7

When does this home calling occur? I can start the programm and go as far as choosing the flash disk (won´t go beyond this point, cause I´m chicken :slight_smile: )

It´s probably the best to wait til Nito comes around with the next release or sends you 0.5.7 (you should have asked him in your post @ awkward). Maybe somebody here has got 0.5.7 and is willing to share it (that would be legal by the way); I would be interested, too. Then, it´s perfectly safe to install the old version over the newer one. No reset necessary.

I can confirm the black screen on startup, btw.

cheers
W

For those of you that have been following this thread, Nito has released version 0.61 (last nite) that fixes the aspect issues when playing back VIDEO_TS using DVDPlayback.frameworks. I have tested it on ATV 2.2 + ATVF 3.3.4 and NTSC at 1080i, 720p, 480p, 480i. Did anyone have this issue under 0.57 or 0.60 while running 1080p? If so please comment on whether this fix works for you.

You can find out how to update to NitoTV 0.61 at this link (and you don’t need to create a new patchstick):

http://forum.awkwardtv.org/viewtopic.php?f=6&t=1262

You can update nitoTV through the DVD > Settings > Install Software menu. 0.61 is out, and it will fix the squished aspect ration problem that appeared in 0.60.

0.61 will be included with the 3.3.5 version to be released next week that includes a few new features we’ve had numerous requests for. Need to get it cleared through QC first though.