Using “wireless audio sync” + match frame rate on Apple TV makes audio go out of sync

(I accidentally deleted my first topic when I was trying to edit it with more information and can’t seem to undelete it. Sorry, forum mods! ••EDITED FOR LANGUAGE••There might be two topics now that are extremely similar.)

I was testing the audio sync on a file (that I later realized was actually out of sync within the file itself) but while testing that I discovered an interesting bug.

If you use the Apple TV 4K built-in “wireless audio sync” function in the video and audio options and let an iPhone listen to the audio, it goes crazy out of sync in Infuse. Weird!
How to reproduce the bug:

On the Apple TV 4K:

  • Set output to 4K SDR 60 hz, match frame rate as well as match dynamic range. (Not sure if these steps matter?)
  • Run the wireless audio sync test on each different frame rate in both SDR and HDR you may use. Important! This means you need to switch the frame rate manually and run the wireless audio sync by holding up your phone to the TV while it goes “bloop-dee-bloope-doo”. You can then switch back to 4K 60 SDR.
  • Now attempt to play a 24 fps (or 23.98 fps, or 25/50) video in Infuse. The audio will be almost a second out of sync! Streaming apps such as Netflix/HBO/ATV+ do not go out of sync, so it would seem to be an Infuse thing, perhaps because it uses the Infuse player and not the standard Apple TV player.
  • It appears you can trigger it easily by starting a file, skipping backwards or forwards a bit and the audio will be out of sync.

My question is since you really didn’t have the need for the wireless sync what’s to say that it wouldn’t go crazy when turned on if you really didn’t need it?

If you turn it off do things work right?

Do you have the ability to test it with wireless headphones or buds to see if it corrects the issue the setting is designed for?

Just curious.

I’ve noticed this issue too. It’s really frustrating because using the wireless audio sync function is the only way for me to play back in-sync whole home audio (my main sound system, driven from an Apple TV, plus a bunch of HomePods and random Sonos speakers). Turning the audio sync feature off deletes the sync data, meaning it must be recalibrated each time it’s turned back on—so continually turning the feature on and off isn’t really a feasible option. As the OP said, this is only an issue in Infuse—other streaming apps and even the official Plex client do not exhibit this problem.

Good to know I’m not the only one!
I suspect the reason is that Plex, Netflix, ATV+ etc. all use the built-in Apple player while Infuse uses its’ own custom one that doesn’t quite communicate in the same way with system functions such as the wireless audio sync functionality. Probably. Maybe? I don’t know, I’m just speculating :smiley:

I think there was a note for HomePod update dealing with sync. Maybe other devices fixed too.

So i am still experiencing this problem, did you ever find a solution?

I actually stopped using Infuse completely—Apple’s restrictions on audio playback can’t be overcome by the devs here, so I use my Apple TV only for music and streaming services, and my Nvidia Shield for Plex (since that supports Dolby Vision and lossless Dolby Atmos).

I have the same Problem. Is there a fix for it?

Some users have reported success repeating the Wireless Audio Sync option with each frame rate you plan to use.

  1. Manually set output frame rate to 24fps, 25fps, etc…
  2. Repeat wireless audio sync steps for each

Hi James,

I have now tried this several times, unfortunately without success. No matter if I try it with or without homepods, the sound is not in sync.

Are you seeing this with all videos, or just a few?

Does the same thing happen if you play these files on iOS or Mac?

It happens with the majority of my files. On MacOS or iOS the files are perfecly in sync.

I have the same issue, have also tried the sync for each framerate.
The videos are in sync on other platforms, problem is only with Apple TV with Homepods Mini.