Using VPN on aTV

I would like to know if anybody can help me with the new upgrade for aTV Flash. I downloaded it installed it and installed hotshield. I’m trying to use Boxee now to watch Hulu and the BBC. But it still tells me that I’m not in the right area to watch it. I thought that was the whole idea of this upgrade?? Can anybody tell me what I have to do to get Hulu and BBC to work. I’m currently in Australia, but I also spent time in SE Asia and europe.
Thanks

There is a guide for setting up a VPN here: http://wiki.atvflash.com/index.php?title=VPN

I’m having issues with VPN too. I installed Tunnelblick but I cannot shift the Tunnelblick option in Settings from Disabled. I have no problem changing settings in anything else - just this one app. Would really appreciate some input here? The Wiki doesn’t offer any troubleshooting guidance.

I too have the disabled option showing for Tunnelblick. I am in Ontario Canada.
Any help apreciated

same here

I’ve been struggling with Tunnelblick too. I got a bit further when I renamed the files as shown in the screenshot on the VPN guide page. Then I was able to switch from disabled to enabled state. However it alone didn’t do it - I suspect I still need to twiddle with the config.conf file. But anyways I wanted to share that you probably need to use exact naming on the files provided by your VPN provider.

The guide says “2. Copy your VPN files (supplied by provider) via FTP to the AppleTV’s ‘Library/openvpn’ folder.”

I am unclear what these files are. I subscribe to the VPNUK service which runs fine of my Mac … but i set that up through System Preferences>Network. What are the files that I am supposed to copy ? Appreciate if any response can take this down to a very basic level; I am not familiar with Unix commands.

Tks

The guide says “2. Copy your VPN files (supplied by provider) via FTP to the AppleTV’s ‘Library/openvpn’ folder.”

I am unclear what these files are. I subscribe to the VPNUK service which runs fine of my Mac … but i set that up through System Preferences>Network. What are the files that I am supposed to copy ? Appreciate if any response can take this down to a very basic level; I am not familiar with Unix commands.

Tks[/quote]

On your mac, go to [UserName] > Library > Open VPN. You should see the files in there. I copied mine over but Tunnelblick still won’t budge from disabled!

What files did you rename and how? In my openVPN folder on my Mac I have ca.crt and MPN UK.ovpn.

You shouldn’t need to rename any files.

aTV Flash will support OpenVPN using Tunnelblick. If you’re having trouble you may need to contact your provider to obtain the proper files for OpenVPN and Tunnelblick. Usually these will consist of a .conf file and a handful of key/cert files.

If Tunnelblick appears as enabled, it is running. You can test that the VPN is working by navigating to a site such as ip2location.com via the Browser. This will show your IP address and location.

Have done that and am awaiting reply from provider. I have copied the files that operate Tunnelblick on my Mac. My issue is that Tunnelblick simply wont enable at all.

I am having the same issue. I have signed up with Witopia and copied the 4 files from their config folder, renaming their .ovpn file to vpn.conf, but I cannot get Tunnelblick to Enable. Hotspot and all other options in that Settings page change to Enable with no problem, but not Tunnelblick. Really hope someone can help.

Support email reply from my Tunnelblick provider, My Private Network after I shared ATV’s instuctions with them:

I think it should be as simple as copying the MPN UK.ovpn and ca.crt into the ~Library/openvpn directory on the ATV.

Make sure there are no other configuration files in that directory as Tunnelblick will not know which one to open if there is more than one.

There is nothing else in the instructions to indicate further configuration, so that should be fine.

Those are the only files in my openVPN directory and it still won’t work. Some help here, please ATV???

Tunnelblick requires a .conf file. Either ask your provider for one, or you should be able to simply change the extension of ‘MPN UK.ovpn’ to .conf

Thanks … but i see no such folder on my Mac. I have also searched for .ovpn files (none) and .crt files (none); extensions other people reference.

You may try contacting your VPN provider and ask them to send you the required files for Tunnelblick.

Is Tunnelblick not enabling because there is something incorrect in the openvpn folder? Or should it enable anyway, like the Hotpsot one does, and then problems would arise afterwards if the wrong stuff was copied into the folder? Basically does it make sense that Tunnelblick won’t even Enable…is that what would happen if the openvpn folder was wrong? Which I don’t think it is, but anyway.

And as a quick follow up to my last post, could there just be something wrong with the ATV or the Flash that might be resolved by doing a factory reset of the ATV and using the Flash drive again? Might that fix Tunnelblick? Though the other people having the same issue makes me doubt it.

Success! This is how I got Tunnelblick to work.

  1. I signed up with vpn provider, and they sent me 5 files:
    ca.crt
    ovpn43.crt
    ovpn43.key
    ovpn43.ovpn
    ta.key

  2. I renamed the ovpn43.ovpn as ovpn43.conf

  3. I then uploaded those 5 files to my Apple TV into /Users/frontrow/Library/openvpn folder

At this point I was able to get Tunnelblick enabled (Maintenance -> Settings -> Tunnelblick), but it didn’t appear to work. Turns out the vpn was working just fine, but it was just the dns that didn’t work. So my quick and dirty solution was to switch to public dns service

  1. I went to my Apple TV network settings (Settings -> General -> Network) and changed my dns address as 8.8.8.8 (Google public dns)

Anyone got this to work with witopia?