Using SMB share when not connected to internet

I have identified an issue with Infuse (both v4 and v5) regarding SMB shares on iPhone / iPad when the local WiFi network is not connected to the internet.

When I connect my iPhone to a local WiFi network which has a storage device accessible by SMB, there is no reason why I shouldn’t be able to stream that content over the local WiFi network, without needing any internet connection. In some cases, Infuse will let me do that, but in other cases it will not.

Firstly, I can connect the iPhone by WiFi to my home router (Netgear) which sends internet around the room. I can then go into settings and disable the internet (or more crudely, pull out the wire connecting it to the model). At this point the WiFi network is still active, just not connected to the internet. My iPhone shows as connected to the WiFi network AND is showing the WiFi symbol in the top left of the screen. If I try accessing a webpage, it is shown to be down (of course). If I try to access the SMB share through Infuse, it works perfectly.

On the other hand…I tried to do something similar with my HooToo Tripmate portable travel router. I connected both my iphone and SMB-enabled storage device to the WiFi network it creates. I did not connect the router to the internet. This replicates a very common situation for me - I intend to use this router while traveling, e.g. in a car / on a train to stream movies wirelessly from the storage device.

All of the above worked fine, except that there is no little WiFi symbol at the top left of the iPhone screen. However the network is still active and I can easily access the SMB share through a number of other apps, just not infuse. If I try to, I immediately (no pause) get an error message saying “An error occurred. Sorry, Infuse encountered an error while trying to connect.”

It appears that something within Infuse is telling the app not to even bothering to try to connect via SMB if the iPhone does not have that little WiFi symbol (I’m fully aware it’s not the symbol itself that is the issue, but it’s a symptom of what’s going on).

I am sure it is a problem with the coding of the app and not anything hardware related, since:
a) I can connect just fine through Infuse using UPnP/DLNA in this situation (movies play just fine)
b) I can use other apps to access the storage device using SMB in this situation
c) If I turn on 3G data on my iPhone with this setup (so the iPhone can once again access the internet, albeit not through the WiFi), then the SMB share works just fine again

Any chance you could look into this? If I’m doing something wrong I’d love to know. I did a load of obvious things like turning off “Fetch metadata” but it didn’t appear to help.

While I haven’t done this with the current version of Infuse, I’ve used Infuse in this exact scenario successfully in the past.

Make sure that you’ve added the SMB share to Infuse using the SMB server’s current IP address that was assigned to the SMB server by the travel router. The normal name resolution services that you might normally rely on may not be available on your travel router, and the IP assigned by the travel router may not be the same as on your home network.

Hi - thanks for the response. However I think I have everything set up ok, if I connect my iPhone to internet (3g) then it finds the SMB share just fine. It is when I turn off cellular internet it won’t even look for the SMB share any more. This is an issue as my iPad doesn’t have cellular internet, also because I would like to use this setup abroad without data roaming.

I’m becoming convinced it’s just a line in the Infuse code which says “Do not attempt SMB share if not connected to wifi / internet” which is causing this. It is a problem as my travel router does not show up as a live wifi connection on my iPhone / iPad, even though it is actively connected (I can access the router settings / perform SMB shares using other apps).