Using Jellyfin as a server, TV Shows don't show up

Hi!

I’m using Infuse Pro (v6.5.9) on an iPhone and 4K Apple TV in combination with Jellyfin (v10.6.4) as a media server. In library view, movies are visible, but not TV Shows, no matter what I try (and I tried a lot :wink: ).

They do show when I go to the Files tab (iPhone) or Jellyfin button (Apple TV), so it’s not so much of a biggie as I can watch TV Shows this way). Any insights would be appreciated.

Thanks,

  • Ray.

A little update: it magically resolved itself, because I added a second TV Show series… which means that Infuse needs more than one TV series to make the “TV SHOWS” tab visible… ? Hmm…

Edit: but then again, I know only see the secondly added show in “TV SHOWS”, and only the firstly added one in “ON DECK”, so it’s not really solved.

Are you using multiple users on your Jellyfin server?

Does the logged in user have access to this show or library which holds the missing files?

Can you check to see if the InfuseSync plugin is installed (via the Jellyfin web UI)? A server restart will be needed after this is installed.

Thanks for your reply!

Yes, multiple users, the one I’m talking about is a “normal” user (no admin rights) and has access. InfuseSync plugin is not installed (I tried before, but it stopped updating).

So the situation is as follows (on iOS): I have two TV Shows, show A and show B. In the Library tab, A shows up under “ON DECK”, but not B. B shows up under “RECENTLY ADDED”, “UNWATCHED” and "“ALL TV SHOWS”, but in either case A is not there. In the Files tab, my Jellyfin server is visible and I can navigate down and see both shows. In the Browse tab, the “On Deck” cell only reveals A, the “All TV Shows” only reveals B. (By the way, B was added later to the server than A.) I hope this is al clear :wink:

I see this both on iOS and tvOS (not surprising of course). You want me to try the plugin again?

By the way, I was thinking of starting a thread for all Jellyfin related issues and suggestions, which then perhaps could be pinned so you would have a central thread for Jellyfin users, would that help you to save time in general and/or have a better overview?

Thanks,

  • Ray.

I would try installing the plugin again (and restarting your server).

I believe you need to log in as an admin to install plugins.

Hi James,

I did install the plugin and it didn’t make a difference, the situation still is as I described above. Hmm…

@james
The problem remains, even after installing all the latest (Jellyfin v10.7.2 etc.)

Do you have a public repository (say, GitHub or similar) where bugs and feature requests can be posted? I don’t think a forum is a good way to keep track of such things…