Used latest Seas0nPass and can't SSH into ATV

I’ve just used the latest version of Seas0nPass to Jailbreak my ATV2 with 4.4.4 and all seems to have gone fine as I can see the FireCore logo on the menu but i’m unable to SSH into my ATV2 at all.

What am I missing?

Nothing? Seems other have had this problem too seems the 4.4.4 just does not work…

I’m having the same problem. I factory restored and then tried to go back to the teathered jailbreak and it didn’t fix the problem.

I’ve just try’d the new version of Seas0nPass and that doesnt work either ;(

Stupid question but are you connecting to the right IP Address?

Yes connecting to both the IP and the Bonjour name both of which time out and refused.

Can you ping it? What is the IP address of the aTV and the Computer you are using? (This is safe to provide as it will be an internal address)

Can’t ping the Apple TV (192.168.1.116) i’m on the same network and subnet and AirPlay and such works fine from the same MBA. The ATV2 was jailbroken fine on previous firmware but I updated to 4.4.4 and have not been able to get it working at all.

I’m assuming the Jailbreak has worked correctly as I have the firecore logo in the bottom right corner but nothing else.

I just want to clarify that you didn’t update the software on the aTV2 through the settings but instead flashed the jailbroken IPSW?

Course, otherwise i’d loose the jailbreak wouldn’t… This is the first time i’ve used Seas0nPass and really wish I didn’t now.

If you can’t ping it there is a problem (obviously which you can see). Are you able to access any network functionality like the Internet Radio? Is it a wired or wireless connection?

What router are you using?

It’s not a network problem the ATV2 can access iCloud and my local network and machines on it.

My router is not a AirPort it’s just a DLink, I don’t think Seas0nPass is Jailbreaking it correctly as even the aTV Flash installer won’t work even when it detects the ATV2 it just hangs when attempting to connect via SSH.

I’d try the jailbreak again. I had a hard time getting 4.4.4 on but once I did it worked flawlessly.

It’s not the jailbreak, i’ve figured out whats going on I can’t SSH to it while both my MBA & ATV2 are on wifi as when I attempted to SSH from my Snow Leopard based NAS it worked fine straight away (this is connected to the router via ethernet).

 

This could happen if you have AP Isolation enabled on the router. It, in essences, allows wireless devices to work within their own network not being able to communicate with other devices.

 

You could check if that is enabled on your router in the wireless settings.

This is happening to me as well,

there are no issues with the router…I have been using the same router with the exact same settings for 2 years no with no issues whatsoever. I use DHCP reservation by MAC address to always assign my atv the same IP address which it is (it shows in DHCP clients section as well as the network config on the atv as having the correct ip) Cannot ping, cannot SSH but internet connection is definitely there (i can watch a movie preview, internet radio, etc)

 

Can someone please advise? I have gone though all the obvious and this one has me stumped…yes I have also already rejailbroken