Use Yadif as default deinterlacer on ATV4K

Hello,

I’m not sure what is wrong but this dvd material look on Infuse really bad “very jagged edges”
I tested this on all my players(MrMC also) and problem is only on Infuse. Please look:


3 Likes

Which Apple TV model do you have?

Since this is an interlaced video, you may try adjusting the Deinterlacing setting found under the Video tab of the Playback Menu (swipe down while a video is playing).

Apple tv 4k 1gen and 2 gen.
I tested Yadif & IVTC and is much better BUT this good/best mode is not selected automatic why?
I have Panasonic UB820, VU Ultimo 4K and I don’t need change anything video is always perfect.

Moving to suggestions. Thanks!

I submitted a support ticket back in 2020 about making YADIF the default de-interlacer. (Ticket #125154). I uploaded video clips requested by Support that illustrated the problem with de-interlacing in Infuse and AppleTV. The last reply from Support acknowledged my upload of diagnostic materials, and supposedly escalated the issue to the Infuse “development team”.

I never received a response back from Infuse support after uploading the materials to Infuse… As far as I know, my support ticket is still open.

Making YADIF - from what I can tell the only option that actually de-interlaces properly - would be a great help.

1 Like

Welcome to the forum!

Don’t forget that you need to click the like button on the first post in this thread to show your support for this suggestion! :wink:

2 posts were split to a new topic: Yadif problem