USB External Drive Not Showing Up!

After a Factory Restore, Smart Installer was able to successfully complete installation.

However, my external USB drive (formatted in Mac OS Extended journaled) does not appear in the ‘Places’ folder in ‘Files’ regardless if I’d connected it directly to the AppleTV or linked via a Hub. Even tried different combinations of reboots.

I’ve also tried unplugging & plugging it back in.

How can I make the USB drive appear? Please help!

[ aTV Flash 3.5.3 and Apple TV 2.3.1; OWC Mercury Elite-Al Pro Dual Drive ]

5/12/09: Updated to aTV Flash 3.5.4, but still no go. USB external drive is NOT mounting. Any ideas?

Did this USB drive work before? I’ve had problems in the past with the drive not showing up, and then magically showing up… Have you sshed in and checked to see if the drive is mounted?

Some drives will be recognized only when being connected AFTER the Apple TV powers on. Some just the opposite, they need to be connected BEFORE the Apple TV is powered on. Most drives work just fine doing either, but some models can be a bit finicky.

Either way the drive should be visible in the nitoTV > Files menu or Files > Places menu.

Dear readers
I have the same problem with my external drive
But when I first start the external drive or later after Apple TV started up it doesn’t matter.

I Formatted the drive as instructed
It used to be a drive for Vista and formatted with my mac book to Mac OSX extended (j)

What can be an solution?
Should i try it with an usb stick of 4 G to look if the usb is working or??

thanks

I’m having the same problem. USB does not show up. I executed the smart installer, used an USB 3.5" disk (with power OSX jornaled), 2.5" disk (FAT32) and doesn’t work.
I can’t see it as well into the diskutil list command or into the /Volumes folder…

Any ideia?

While looking with the system_profiler looks like there is an external storage

USB:

USB High-Speed Bus:

  Host Controller Location: Built In USB
  Host Controller Driver: AppleUSBEHCI
  PCI Device ID: 0x27cc
  PCI Revision ID: 0x0002
  PCI Vendor ID: 0x8086
  Bus Number: 0xfd

    External HDD:

      Version: 8.17
      Bus Power (mA): 500
      Speed: Up to 480 Mb/sec
      Manufacturer: Western Digital
      Product ID: 0x0707
      Serial Number: 57442D57584E5830384E4139313337
      Vendor ID: 0x1058

some help will be appreciated.

tks

The problem was solved with the complete restore of the ATV, applying the last update of the ATV, installing ATV Flash and running the smart installer. Finally the HD is showing up.