USB external drive as Primary - iTunes does not see space

I followed these instructions (http://wiki.atvflash.com/index.php?title=USB_Storage#Option_2:_USB_as_Primary_Storage) to set up my external USB drive as the primary storage. All seemed to work, it said it was formatting etc, but when rebooted the storage space was still the storage space of the internal drive (both from viewing in iTunes and from Settings > General > About).

From the Maintenance menu it still says the storage is External. If I go back to Internal it reboots and comes back fine, everything works identically. When I switch to External again it asks me if I want to change, I say Yes, it reboots and comes back and same thing - it thinks it is using External, but the storage space is exactly the same as it was with internal (30 GB).

Please help!

What type of drive are you using? If WD, you may need to remove the ‘Virtual CD’ software.
http://www.wdc.com/wdproducts/updates/?family=wdsmartwareutilities

Hi guardianmax, thank you for the prompt reply. I do have a WD drive, but it is older than the one that is mentioned in the article that you posted a link for. I have the 500GB WD My Book Premium WD5000D032. I tried to use that firmware updater and it does not recognize the drive since it is a different family of drive. I don’t think this particular drive type has the Virtual CD software (if it does, I couldn’t find anywhere that mentions it or that has an update that allows it to be removed). Please let me know if you have any other ideas.

I am having the exact same problems with a Hitachi SimpleDrive 1TB? Any ideas?

I’ve tried reformatting the drive and trying again. ATV seems to remember the drive still, as it doesn’t give me the dame options it used to in terms of allowing me to choose the drive. after I click “external” it just reboots and says its on the external drive but it isn’t.

There still may be some software on the drive that could be causing a conflict. Your best option would be to revert back to the internal storage mode, and reformat the drive (including optional step #4) using Disk Utility as described in the link below.
http://wiki.atvflash.com/index.php?title=Troubleshooting#My_Flash_Drive_No_Longer_Works_After_Installing_aTV_Flash