USB Drive Not Showing Up - Multiple other problems

New ATV user here. Purchased it soley to add an external USB drive.

I use PC and the drive in question is a 2TB Western Digital drive in a NexStar USB case formatted in FAT32. I can see the drive on my PC when connected to the computer and can successfully copy files to and from it with no issues.

I have run the Smart Installer twice so far and restarted as requested.

If I have the drive powered up and connected when I restart AppleTV, then the restart hangs.

If I connect the drive after the main menu comes up, then try and change my storage from internal to external, it says “no external drive attached” and when I press “menu” button to restart finder, the restart finder hangs. I have to disconnect the drive, restart AppleTV with a power cycle to try again.

So far, pretty frustrating. Any help is appreciated.



How was the drive formatted? Windows tends to get a little weird when attempting to format larger drives in FAT32. We have a guide for easily formatting the drive in FAT32 here:

Alright, I got one of my AppleTV’s converted, and recognizing a 1tb Lacie HFS USB drive. All good on that one.

So, I thought I’d just go buy another 1tb HFS Formatted Lacie drive and convert my other AppleTV - no such luck. ATV installs fine. Smart Installer installs fine (no errors) - I am able to see the Lacie drive in the Maintenance menu and direct AppleTV to use it as external storage - HOWEVER, iTunes (even after multiple restarts of AppleTV and iTunes) only sees the AppleTV as having a 140gb drive, where my other AppleTV that has been converted successfully shows as 989gb (1tb).

So - any thoughts?

I have started the AppleTV with the drive connected. I have waited to connect the drive until the menu comes up. I have directed the storage back to “Internal” and then rebooted and then back to “External” and rebooted - all for nothing.

I need some help please.

Do you know if the drive has any pre-installed software? Often times some of the pre-installed software is not AppleTV (OSX 10.4) compatible and can cause issues such as this.

If you’re drive came with a software cd you may try running the removal or uninstall application from the cd.

I have no idea - I bought a HFS formatted drive just for this reason - and it is the EXACT same model that worked flawlessly on my upstairs AppleTV.

If is hook up this HFS formatted drive to my PC, I doubt I’ll be able to do anything to it unless I format it in FAT32, and that’s what I was trying to avoid by buying an HFS formatted Lacie drive.

So - no other options?

You may try connecting it to your PC to see if it’s recognized. If needed you can download to the free trial of MacDrive to re-format the drive in a Mac format, or use the guide in the link above to format it in FAT32.


So - further frustration.

Win XP sees the drive in Disk Manager, but because it’s a MAC formatted drive, can’t assign it a drive letter.

And the utility to format the drive in FAT32 REQUIRES Win XP assign the drive a drive letter.

So, I’m stuck.

If your software would just work, I wouldn’t be stuck.

Any other thoughts?

I had the exact same problem with my 2Tb external hard drive to solve the problem I went in to the apple tv and setup the hard drive as primary which apple picked up the hard drive and reformated it into the correct format then I deselected it as primary and I was able to use it as an external USB HDD for storing my movies and music again . one other thing you mentioned that windows XP would not assign a drive letter to your drive are you using mac drive?

I have tried just about everything.

I have reverted the AppleTV to original settings, reinstalled aTV Flash, reformateed the drive to FAT32.  Hooked up the drive and AppleTV and changed the storage to External - AppleTV says this may take a while, but when I go to iTunes my AppleTV says 144.63GB capacity and it is filled with "Other".


So - this program doesn't work. 


I bet I don't get any response from this support forum either.  It's been almost 2 months and everything that has been suggested doesnt' work.

After switching to external storage was the AppleTV synced with iTunes?  Usually this will clear up most issues like this.