Upgrading to Lion help


I’ve upgraded my Mac to Lion and now can’t get either of my AppleTVs to connect via SMB.  From what I can tell nothing has changed - file sharing is still allowed etc etc but I can a “connection refused” error on both devices.

Is it me, is it Lion or is there a gremlin somewhere



Yes, I have a same problem and i could not find any solution.


same things for me…

Tech Support Please…


Same problem…:frowning:

Same issue here.  It’s OSX Lion that has changed something.  I can not connect using SMB or AFP.  In both cases, negotiation fails and will not connect.  I can however connect through my Windows system to my MacMini using SMB.  Whatever it is, it’s inside ATV.

Same here.  I share files on a Mac Pro using AFP.  Has worked for years.  After upgrading to Lion my ATVs can no longer mount via AFP.  

I tried to access the shares from a Mac Book Pro and couldn’t get to them either, which told me I had at least some problem with Lion.  On the Apple forums, I found the advice to go to the Sharing pref, click options and click off AFP, leaving on SMB.  This did let the Mac Book Pro see and access the files on the Mac Pro under Lion.  

I changed my Mount via Nito to be SMB.  However, that still doesn’t work and I get an error message from Nito TV when trying to mount the shares.  So I think there is something that ATVFlash has to fix.

I have logged this issue using the submission request feature.  Will let everyone know if/when I hear anything


To add some detail that might be useful, OSX v 10.4.11 (Combo Update) was used when ATVFlash was first installed on my Apple TV. That is what is in the Documents folder on my Apple TV.

Has anyone confirmed that a Mac with OS X 10.4.11 OS is supposed to be able to connect to an AFP volume shared under Lion?


We’re aware of the SMB issues in Lion and are looking into a few potential solutions.

We should have more details available soon.

So I rolled back my MacMini to Snow Leopard and all is well again.  Thank you Carbon Copy Cloner !

If there is anyone who has  a 1st gen ATV who has been successful seeing shared files on a Mac after upgrading that sharing Mac to Lion?  If so, can you tell us what version os OS X you put on the ATV when you first installed ATVFlash?  Also, if you were successful were you sharing with AFP or SMB?

I have a version of Tiger (10.4.11).  I’m wondering if that is the problem.  It might be so old that no one thought about using it on a client (our ATVs) to access Lion shared volumes.

Same issue, any updates?

I have the same issue, do you know when it should be solved ?  


Thanks in advance

Hello all,

Though not a Firecore user, I did have the same issue with XBMC on both ATV and XBOX not being able to access SMB shares on my iMac that I had upgraded to Lion. It seems Apple has changed SMB in Lion, and that is what has broken things. There is a workaround (possibly more than one) which I found here:


It is a little involved, but it worked perfectly for me.

I like Sharkus’s post, though it’s too involved for the general user, including for me. Is there not another way…anyone? :slight_smile:  Any help would be appreciated.




James, altho you mention SMB issues, would you agree the same problem exists with AFP shares?  Any progress?  I posted a question about whether you know if OS X 10.4.11, which is what I used on my 1st Gen ATV actually works as a client for a Lion share.  It could be that the Nito Smart Installer now loads in a different version of OS X.  I bought ATVFlash way back when I had to manually put a version of OS X on the Apple TV and 10.4.11 combo updater was the recommended .dmg to load.

Thanks for any help!


Just bought ATV Flash and think this is the problem I’m having getting shares working. I can’t connect via SMB or AFP I just get “mount_smbfs: negotiate phase failed”

Any news on a Lion update?

This possible incompatibility with Lion  of ATVFlash on the 1st gen ATVs  was reported to FireCore on 7/21.  Someone said they ‘logged’ the error on 7/28 after numerous similar reports.  It’s now 8/15 and no word back.  

I would find it really helpful if FireCore would tell us what they have learned.  It would be of some value just to know they confirm there is a basic problem with the way ATVFlash works on the 1st gen ATVs when Lion is the source of the AFP or SMB shares.  Is there a problem with using a client based on Tiger (10.4.11) when the sharing device uses Lion?

Can you guys give us some feedback, please?


Does anyone read these forums? All I need to know is either no it doesn’t work with Lion so I can arrange for a refund or yes it does work with Lion so I can be told what I’m doing wrong. I’m hereby invoking my “Satisfaction Guarantee” :stuck_out_tongue:

Give us some answers please.