Upgrading Primary External USB Drive

ATV Version: 2.4
ATVFlash Version: 3.51
Operating System: Windows 7 Ultimate
Others: Using external USB 500GB as primary drive

Requirements: Upgrading 500GB primary external to 1.5 TB

Background Information:

I attempted to clone my primary 500GB USB drive using Acronis and Ghost and apparently this was not an option. The original drive is seen as “Unallocated Drive” therefore can not be cloned. I have had numerous problems creating a new bootable USB stick every time I have been updating my ATVFlash. I have already bought and used 5 USB memory stick and consequently, every time I use it, it can not be used again. Although I’m using Windows 7, I have purchased MacDrive for Windows to format the USB stick but regardless what format I have tried I always have problems with the USB stick. The creation of USB ATVFlash memory stick seems successful during the whole process but it won’t boot on the ATV. I have also observed when the process of copying the ATVFlash files to the USB stick that it takes only a couple seconds and then it prompt me “Successful…” immediately, that tells me that it was not done right.

Questions:
1. Is there a way I can save what I have on my 500GB so I can upgrade it to 1.5TB?
2. What is the best process in upgrading my Primary External USB drive?
3. What is the most current stable version combination with the ATV and ATV Flash?
4. On worst case scenario, would it be possible if I send in a new USB memory stick for ATV Flash install before I renew my subscription?

[b]I’m presuming I would need to reset my ATV to factory defaults and reinstalling ATV Flash by purchasing again another USB stick. I just want to know what I am up against before I dive into this again since my past year of building the ATV Flash memory stick has always been a problem.

Your comments and suggestions are greatly appreciated.[/b]

Its just disappointing that a product with so much potential has very little support from its developers or support staff. I emailed them , filled up the contact form, and even called them and left a message. Not one of those attempts were answered nor was this forum post.

Regardless, I went ahead and renewed my purchase. I did what I know can get me updated. First I ftp’d to download about 60+ of my DVD movies for backup. Restored my ATV to factory settings, updated my ATV to the latest version, reinstalled latest ATV Flash 4.1.1, then re-synced my iTunes. Im now in the process for FTP’ng back my movies to the new external 1.5 TB drive which by the way is taking forever. Im seeing about 3 DVD/24 hrs. Im seeing transfer rates of about 5-12 Mbps with my gigabit network. 60+ DVDs took me less than a day to ftp/download but for some reason upload is 10% the speed than it should be.

Cloning a drive used for primary storage may be difficult if you are not using a Mac computer. Your best option may be to revert to internal storage (through Maintenance --> Settings menu) connecting your new drive, and switching back to the external for iTunes storage. This will require all the files to be copied and synced to the new drive which may take some time but it will definitely get you going.

Also, there was an update released yesterday (4.1.2). This update can be installed through the Maintenance --> Manage Plugins menu. Reinstalling via USB will not be required.

Its been more than a year since I updated and now I am interested to update my ATV Flash again to the latest version. I’m using a 1.5 TB external USB drive with maybe 1TB used space by iTunes movies and music and also maybe about 60 DVD ripped movies.

For some reason I felt the urge to update though “Smart Installer” and XBMC update and now every time I try to view my movies in Nitotv, my finder/ ATV reboots. I tried hard booting both the ATV and the external drive but I am having the same problem. My questions are:

  1. Will reinstalling or updating my ATV Flash to the latest fix my problem?

  2. What is the best route in updating my ATV Flash with 1st gen ATV using external 1.5 TB USB drive?