upgrade possible?

I have an Apple TV (2nd generation) that is jailbroken with Seasonpass on 4.4.4. I was a little late getting to the party with 5.2 because someone stole my mini USB cable and by the time I ordered and received a new one in the mail, Apple had stopped signing 5.2. As I understand, 5.2.1 is now current FW being signed, but it fixes the bug that allows JB. 

 

When I run Seasonpass now to upgrade my ATV2, I get an error from SeasonPass that the iTunes restore script failed. When I manually select the SP 5.2 firmware in my library folder, I get an iTunes error that I am not eligible to restore to that firmware. !   :o(

 

Since I am already JB’ed on 4.4.4, can I somehow make a custom IPSW to upgrade to 5.2? I am on a Mac, so I don’t have access to iFaith or anything like that on windows.

 

----- UPDATE -----

I am thinking that it may be possible for me to upgrade still, perhaps because I had Apple TV Flash Black installed. First I went to the Maintenance menu on the Apple TV, and noted that it had auto backed-up my firmware SHSH blobs to Cydia’s servers for 4.4.4, 5.0. 5.0.1. 5.0.2, 5.1. 5.1.1, and 5.2. LUCKY!

So I plugged the ATV2 into the power source near my laptop, and connected the miniUSB cable to my laptop. I launched the latest version of Tiny Umbrella. I clicked save SHSH and it saved the SHSH blobs from Cydia’s server to my local hard drive.

I followed a guide here if this is difficult : http://www.coolestguyplanettech.com/saving-shsh-blobs-from-cydia-to-local-directory-with-tiny-umbrella/

Next I wanted to build a custom firmware, stitched with the 5.2 SHSH blobs and jailbroken with SeasonPass. I read that SeasonPass now supports stitching Blobs to custom firmware, so made sure that the ATV2 was plugged in and tried right clicking on “build ipsw” and selecting 5.2. The install script for iTunes worked, but iTunes gave an error of 1600.

I tried launching a VM of winXP to download iFaith, which did pretty much what TinyUmbrella did. I then ran Sn0wBreeze in iFaith mode to generate a custom stitched/jb’ed 5.2 firmware for ATV2. The firmware was built, and I put my ATV2 into DFU mode and tried to restore in iTunes with the custom firmware from Sn0wBreeze, but I got a 1604 error.