updating possible?

Hey there

I have an ATV2 that I’ve jailbroke and did the whole process and was very pleased with the result.

lately i’ve updated my os and I want to use the new feature and mirroring my computer to the TV.

now comes the problems, the mountain lion (the os) says that they apple tv firmware needs to be updated, the firmware now is 4.4.4 and i want to update to 5.1 (5.0.2).

I tried to just download the new files from firecore and install it on the atv2, didn’t do much since it’s just upgrade the atv2 flash

I tired to use Seas0nPass to jailbreak it again with a newest firmware, didn’t work, I get stuck when plugging the the atv2 to the computer, i do all the steps but the the atv2 doesn’t connect to the computer, it won’t recognize it

I tried to update the software through the apple tv itself, didn’t work, says my apple tv is uptodate

I tried restore the apple tv, didn’t work, says can’t update software


any ideas out there?



If you cannot get iTunes to recognise the ATV then you will not be able to jailbreak it with later firmware, or even get it to standard software with later firmware.

The question therefore is going to be to work out what is stopping the initial connection. Thoughts that occur to me are:

  • Check the micro USB cable. Many are not up to the job. Some are data only (you need a charge+sync cable) and some have very thin connectors internally so they cannot power the ATV well.
  • Make sure you are connecting directly and not through a hub.
  • potentially try a different USB port on the PC/Mac in case the one you are currently trying has a problem. You may want to also try a different machine.

Thanks for your answer


so now I have another problem, I’ve updated the ATV to 5.1 and since there’s nor JB for that I’m stuck

I’ve saved the SHSH with tinyumbrlla so now i;m trying to downgrade from 5.1 back to 4.4.4

but it won;t go to DFU

any idea why?