Updating Metadata hangs indefinitely on several titles

I’m going through my library to correct several mismatched titles. Most of the titles I can update without issue, but several titles won’t update properly:

On problem titles, when I Edit Metadata and find the correct title in the database, clicking the correct movies causes the spinning progress wheel to go on forever, it appears to hang applying the metadata for some reason.

My library is stored across three NAS devices, and I’ve had this issue occur with titles on different NAS devices (from two different manufactures, Netgear ReadyNAS and Synology) so it doesn’t appear related to the storage device itself.

Anything I can try to get these titles corrected?

Can you provide a few video titles that are hanging?

If you go back after a while and try again do they complete the edit?

Strangely, a few of the titles I was having problems with managed to fix themselves, but continuing to go through my library, I had freezes on several other titles and gathered some more info:

So far, all of the further problematic titles were on the same NAS device: a Synology DiskStation.

In going to my Library and checking for Changes, I am getting an “indexing failed” message on the Synology. My other two NAS devices (both Netgear ReadyNAS’s) are indexing fine as usual, and the Synology in the past has also indexed just fine.

The Synology is running both SMB and AFP File Services.

Further, when I attempt to Edit Metadata on mismatched titles on this NAS device (and the spinning wheel goes on forever after clicking the correct matched title), the affected titles lose their Cover art and are reclassified as “Other” (rather than “Movie”) and are now stuck in the limbo of the Other Folder.

So the issue appears to be related to the a failed indexing of the Synology DIskStation, which again has indexed just fine in the past but is now presenting the “indexing failed” error message.

Any ideas?

First, in the settings for the SMB Synology share under “Saved Shares” > “Edit Share” do you have the name in the “Address” field or the IP address? The name is easier but if you do have the IP then you need to make sure you have that IP locked in your router for the Synology NAS.

Second, under the “Advanced” settings on that page you’ll want to make sure you have the MAC address. That will help with the wake commands.

I have the name specified in the Address field (not the IP address), but I do not see any reference to the MAC address in any “Advanced” setting pages. Perhaps this was changed/moved in more recent versions of Synology’s DSM software?

In the Infuse Settings go to “Shares” then “Saved Shares” then select your NAS then go down to “Edit Share” then down to “Advanced”. There you should see "SMB Version, Port, Workgroup, and MAC Address

That is where you enter the MAC address of your Synology. Note if you Synology has two Ethernet ports they may have different MAC addresses if I remember correctly so make sure you get the correct one. The Mac address should be on an sticker or in the configuration settings of the Synology.

Ah, I see—I made the updates to Infuse’s settings. After entering the device’s MAC address, it did seem to initially help… but the problem cropped up again as I continued going through to correct mismatched titles.

Something I’ve noticed this time around is that when I go to Edit Shares, I am getting an “Error Occurred: RPC session disconnected” on the Synology device, whereas the two ReadyNAS devices are fine.

The NAS is definitely still mounted and connected and the directory read without issue in the Finder, so I’m not sure why the RPC session is becoming disconnected or how to re-establish a connection.

Also, I noticed when I Edit this Share that the username & password are greyed out—I typically log into this device with my Admin account, but currently it shows the default “johnappleseed” account without the ability to change it. Perhaps part of the issue is that I’m not logged in as an authentication user from Infuse?

I’ve just tried forgetting the Share and re-adding it—this time specifying my usual username/password to connect, in addition to making sure the MAC address (and Workgroup) were filled out.

It initially began to repopulate but while I was going through to correct mismatched titles (again), it began overwriting all of my local Cover artwork with versions pulled from the internet—and a few seconds after that, I was ejected from the Library window and began receiving “An error occurred: ErrorCode 0xc000011f” and for now can no longer connect at all to the Share.

#thinksinc

I have the same problem as you describe in your post on oct 14…
I also did everything what was suggested but the Infuse app still shows the same problem RPC session disconnected, and the app does not play any video…

What is the solution ? Dear #moderator any idea how to keep RPC session always in session?

I never got it working. I ended up switching my Infuse source to Plex, which was a better fit for me: it respects the Sorting Titles from Plex I use to get movie series in the order I want without using terrible automatic Collections, and I can use Infuse’s Poster-only view (no titles beneath the poster art) which doesn’t seem like Plex will ever support. Best of both worlds for me.

#thinksinc
Got it…
I’m trying to look closely the setting in Synology and try to figure which one i have to change in order to get a smooth and stable connection between Synology Nas and Infuse… I suppose that we would not get valuable assistant from Infuse or from Synology either… We are left on our own to figure it out with trial and error… If it works smoothly I can share my finding with you… and the whole Forum here.

Can you try adjusting the SMB version in Infuse as described here.

You may try using SMB2 or Legacy to see if things work better.

Thank you… I’ve tried…it’s ok I have matched the SMB setting i have on Synology with the same setting in Infuse… it works better now, but sometimes I have the same message “RPC session is not in progress” … later on it came back… I hope it will work well later on