Updating ATV to 2.3

I have an issue with the update to ATV 2.3 which I hope someone can help me with.

I restored my ATV to factory default which was version 2.0
Did the first Apple update which took it to 2.1
then did a further update which then took it to 2.2
tried several times to do a further update to 2.3 (but get a message that the ATV is up to date)
In the general General>Settings>About screen it says my firmware version is 2.2
Whenever I go to the movies menu and click on any of the submenus I get a one line message which says “An update is available for you Apple TV” but yet I cannot update to version 2.3
The Setting Menu also displays Airtunes as an option (I think this is only available in version 2.3)
So now I’m not sure what version of ATV firmware I am running.

I have also done a factory restore three times and updated the ATV again but still no 2.3 firmware.
I have also left the ATV in this state for one week just incase the update had not propagated to my region (Dubai), still no luck,

Someone please help and let me know what I can do to resolve this issue.

Are you trying to update with or without aTV Flash installed? The AppleTV can not update from 2.0 to 2.1 or 2.2 anymore, it would only update from 2.0 to 2.3 directly. To get 2.1 or 2.2 you’d have to edit the Restore image or have the AppleTV point to a fake Apple update server (I’m working on that now.)

I previoulsy had version 3.33 of ATV Flash installed.
I did a complete restore back to the factory default (2.0) firmware thus eliminating ATV flash
I then did an update which updated ATV to 2.1
then did another update which updated ATV to 2.2
I cannot seem to get it to update to 2.3
I have not at any stage tried to reinstall ATV flash

Strange that you say that you can upgrade from 2.0 to 2.1 then 2.2 in succession. As madcran indicates, one cannot upgrade from 2.0 to 2.1 (once Apple releases a newer version of the ATV, your ATV will only see that version unless you redirect the Apple TV’s update process to a bogus server (on your local network for example) If you did not attempt to modify the “version.xml” file and redirect the mesu.apple.com host, your AppleTV should not be able to upgrade from the original version (in your case, 2.0) to 2.1. If what you describe is true, then you will be the first that I know of that can upgrade from 2.0 to 2.1 (since Apple has since released 2.2 and now 2.3)

As for suggestions, you seem to be properly going about it by reseting your ATV, then upgrading via the ATV software update menu.

Anyway I am on line today, (no holiday here in Canada!) and would be happy to help… so let us know of your progress.

Thanks for you suggestions and offer to help.

I did the restore and update one mote time and this time checked every step to see if I was doing something wrong along the way, I noticed the following;

did the restore to V 2.0,

then selected the imac to connect to ATV,
did not sign into itunes or choose a country
did the first update V2.1
did the second update V2.2
signed into iTunes and choose USA as the store
went to the movies menu and what appeared at the to was a line informing me that an update was available
go to update software
Message: ATV is up to date

Now I will try signing into the itunes store from the first update and see what happens, I’ll let you know if it works or not.


This time I restored to V 2.0
Signed into iTunes and selected USA as country
Did first update (2.2)
Still signed into iTunes (country USA selected)
Go to movies>Top movies,
First line says, “An update is available for your Apple TV”
Go to Settings>General> and select Update software;
Message returned - Your Apple TV is up to Date
Check Settings>About - Software version 2.2

Any suggestions how to get to Version 2.3?

The only thing I can figure is that something with being in Dubai is causing the problem. Maybe an Apple server in your area or for your region has not been propagated with 2.3 yet. I still think it is interesting that you can go from 2.0 to 2.1 to 2.2, no one here in the States can do that, I am forced by Apple to go from 2.0 to 2.3 if I try to update using the Settings menu.

When i did the last restore and update i was able to go from version 2.0 - 2.2 straight without going to 2.1, but I am still not able to go to version 2.3.

I also suspect it may have something to do with the servers but can’t be sure.