Updating Apple TV to latest iOS

I looked around, and didn’t see, or couldn’t find a guide for how to properly upgrade my Apple TV to the latest release of iOS that just came out for it. I already have it Jailbroken. Will I need to repeat the entire process again? Installing a fresh version of iOS, then running Seas0nPass, and finally installing aTV Flash (black)?

I have the same question. Specifically, I am running aTV Black 2.2 under iOS 6.0.1 and want to upgrade to iOS 6.1. Do I start over with a fresh jailbreak?

Yes - you start over again with a fresh jailbreak.

Since you are using ATV Flash you can use the Backup option in the Maintenance app before you start to back up your current settings and metadata.   Then when you have redone the jailbreak on 5.2 and re-installed ATV Flash you can use the corresponding Restore option to get back that saved data.

Thanks! That would make a great entry in an FAQ list.

 

I have an ATV2 with iOS 4.4.4 and aTV Flash 2.2-1.  How do I upgrade it?  I understand the part about using the Backup option in the Maintenance app to backup the current settings. But then what?  How do I “redo the jailbreak on 5.2”?  How do I get it to 5.2?  (I do NOT want to get to 5.2.1, as a tethered jailbreak is not an option for me).

If you do not want to go to 5.2.1 (and the tethered jailbreak), then you can only go to the releases that show up as having saved signatures when you use the ATV Flash option to backup signatures. This may include releases later than the one you have installed. If any later ones do show up then the list of jailbroken releases and the jailbreak type can be found at http://forum.firecore.com/topic/3418

 

@itimpi,

Please forgive a neophyte question, but how do I show the list of releases that have saved signatures? I can’t find the aTV Flash option you mentioned.  Under the aTV Flash Maintenance/Settings menu,  there’s a menu item Manage Backups, which in turn offers Backup My Settings, Restore From Backup, and Backup my Firmware. I don’t see a way to view a list of any releases (with saved signatures). Nor to backup signatures.

What further puzzles me is how to actually update the ATV2. I looked at Apple’s Settings/General/Update Software, but it tells me the software is up-to-date,  even though it has 4.4.4 (build 3330). I presume the jailbreak (wisely) disabled this option.

Do I use Settings/General/Reset/Restore?  That apparently will “restore your Apple TV to its factory settings. Your Apple TV will also download and install the latest software update”.  Will that download and install 5.2.1?

Or does the ATV have to be connected to a Mac and updated somehow using iTunes?

 

Many thanks for your help.

Doh!  I’ve found that one has to click on Backup My Firmware (in the Manage Backups menu) in order to reveal the list of saved signatures. That’s not at all apparent to the uninformed user (me!).

The list that is displayed indicates that saved signatures exist for 4.4.4 (what’s presently installed on my ATV2), 5.0, 5.0.2, 5.0r1, 5.1 and 5.2.

I’m still stumped on what to do to upgrade the ATV to any of these releases, say 5.2. Do I use iTunes somehow to do a factory restore, then run Seas0nPass, then reinstall aTV Flash (black)?? There must be a step-by-step guide posted here somewhere, but I haven’t found it.

Thanks.

Full details on saving, and using firmware signatures can be found here.

I followed directions in article 359097: Using saved signatures to install an older version (this would not have occured to me, since I’m trying to upgrade from 4.4.4 to 5.2).

Step 1:  Connected my ATV2 to MacBook Air using microUSB

Step 2:  Launched Seas0npass v0.9.0

Step 3:  Right-clicked and chose version 5.2

- > Seas0npass errored: no ATV device connected.

I ran System Profiler, and verified that the ATV is visible to OSX. It is.

Tried running Seas0npass again.  Same error.

As I recall, back when I first installed aTV Flash (many many months ago), the procedure required plugging/unplugging the power cord. Today, I simply followed the steps in the article. I did not unplug the power cord, nor the HDMI cable, nor the ethernet cable. Could that be why the ATV is “not found”?  Should there be a Step 0 in this procedure to unplug some/all cables before connecting the micro-USB cable?

 

 

I am having the same problem. I have a jailbroken AppleTV gen 2 with the last version of software on it that allows an untethered jailbreak, but I want the new version so I can use HBO Go. How do I update the AppleTV so I can then re-jailbreak?

I went ahead and restored it to newest iOS, so what now? I ran SeasonPass and now my AppleTV won’t start up entirely whether it’s plugged in via USB, without via USB, anything. The most I get is the Apple logo and then a black screen with a flashing LED on the unit.