Updated Remote HD and now Apple TV is bricked

The Remote HD update bricked my Apple TV. How can I restore it?



I’m just going to update the software and start from scratch. But perhaps a heads up to anyone else thinking of updating Remote HD.

If you restore through iTunes then jail break it again, it might be ok.


Same here, just updated and it bricked the aTV2.

Losing my whole XBMC library and add-ons ain`t no fun.

dont restore


like everyone does upgrades there packages…remotehd update made my atv2 show blank screen on 4.4.3


if this has happened to you this is the fix

use putty and ssh in and type commands and hit enter after each command

“this removes”

apt-get remove remotehd-atv2



ssh back in again

“this downloads older version that worked”

wget http://www.remotehd.com/Downloads/ATV/FireCore/remotehd-atv2_4.3.6_iphoneos-arm.deb;


“this installs it”

dpkg -i remotehd-atv2_4.3.6_iphoneos-arm.deb



hope this has helped people…RemoteHD shouldnt release non stable product until fully tested

Hi mikey, thanks for the feedback !

I tried to ssh inside it before restoring but couldnt remember the IP, shame on me.


Anyway, its already restored. I will never use RemoteHD again, releasing an untested stable version is just nuts.

Thanks once again for the step-by-step.


Best regards

Glad it wasn’t bricked!

Hello. I never post on here. But I’m super desperate! I installed Remote HD 5.0 and it is causing my ATV2 to get stuck in the reboot cycle. Thus, I can’t connect using putty or any other wireless SSH program.

Is there a way I can SSH using a wired connection?

I really want to avoid having to do a full restore. SeasonPass never actually jailbreaks the ATV 2 correctly the first time. I end up having to do it 3 or 4 times. I have jailbroken around 10 ATVs for friends and family. I tell them to buy the pre-jailbroken ones on eBay because I don’t know why SeasonPass doesn’t work for me.

If you can help me I can send you some awesome XBMC zip files. Any movie or TV show you want. Even movies in theaters now.


Hi, I presume you have unplugged the ATV2 for a few minutes and then tried to start it again? If you get in this way try to un-install the remote HD.

If that fails you will need to restore and then jailbreak again. For me the biggest difference to everything working well was to make sure iTunes was loading well and not taking ages to load. Once I reinstalled iTunes (it kept my library). jailbreaking and restoring worked first time and every time for me.

Another tip is to change the password as soon as you get in after a jailbreak and before you install things like Nito TV.

Good luck!


Yea. I tried all of that. Oh well…I guess I might as well re-jailbreak. It was a good run! I was on iOS 4.2. lol.