Update never Happens (Stuck at "in progress")

This has been ongoing, I think since I installed infuse on my ATV4K

I didn’t say anything, as I hoped this new update with tvOS and infuse would fix this.

I cannot properly update my library,

I go to library, says “last update 63 days ago…in progress” spinny circle.

Never changes, EVER.

Tried infuse on iOS with same library, updates and gets meta data perfectly fine.

Any help?

Hmm, if it hasn’t updating in that long it’s likely something wonky is going on…possibly related to one of the iCloud outages from this summer/spring.

A few things to try would be to use the Clear All Metadata option found in Settings, or just remove and reinstall the app.

Either option will cause Infuse to fully refetch your library, which may help get things going again.

Tried removing the library, re adding.

Tried uninstalling, reinstalling, re-adding the library.

I get “in Progress” “pending” over and over and over again.

So I went to the Movie Folder, let it load all the covers (kept scrolling line by line till they were all loaded).
Then went to the TV Folder and did the same.

Went back

Last update: Never
Status: Pending or In Progress

Tried update on phone, it fetches meta data and thumbnails with (1234/5000) etc etc.
Tried new install on ipad, it fetches meta data and thumbnails with similar numbers.

No progress on apple TV.

Have you tried turning off iCloud and then restarting Infuse? Just a shot in the dark.

Tried just leaving iCloud OFF and then going back in (restarting atv4k).

Same thing.

However, if I go to a new show/movie, it will load the thumbnail, then a moment later load the synopsis etc etc.

But the update says “never” and still “in progress” “pending”…

Maybe itll just take a while longer than 30-45 minutes. I will try and leave this running overnight tonight and see.