Update Crashing Metadata Compile

A little expansion on “thanks” would help here James - ???

The Caching issue doesn’t apply here - as the metadata has been cleared completely by the ATV ??? So that’s CERTAINLY not going to help - just look at one of them that’s done a 4th restart on compiling the DB and it stands at about 15gb - which the ATV still does not accept as “safe” - my ONE AND ONLY 64gb ATV is ok :frowning:

Please update me

Would you be able to submit a report from one of the problematic devices (and post the code here)?

This may provide a bit more insight as to what is going on.

James - I’ll do it with pleasure but surely you appreciate that there is nothing wrong except for the new size the graphic downloads take up …… previous 7/9gb caused an Apple delete very occasionally (I think I’ve only seen it once or twice before in the last 12 months) but anything above 14gb on a standard 32gb ATV is going to be clearly too big - so unless you can limit the size of the graphics download there will be no fix …. The proof of it is that before update it was 8/9gb - and now a CLEAN install is double the size …….

The code showing at the moment is: Z4XE8

but at this moment it’s only showing 122mb and has completed 3,974 movies and 26,280 TV episodes with another 20,144 still left to complete - it’s going to be really difficult to send another code at the end of the step 2 (graphics downloads) because when it reaches the end - it wipes itself and starts again !!! - I’ll try if I can to get another code in the morning.

Simon

Just a thought for you though - here is the code from the 64gb ATV5 that does compile without Apple deleting it:

4TWH8

Currently using 18.2gb of data - BUT that does include an estimated 3gb of cached images and data (I know that because the missing TV episodes are still showing as ok on this device and I’ve compared it to the CLEAN install from the 32gb ATV4 that ends at about 14.5gb)

This however should enable you to see how the device is using so much data for 7.1

Simon

1 Like

7 x ATV’s 32B - now COMPLETELY UNUSABLE thanks to 7.1 !!!

AND ???

In addition to quicker purging of old TheTVDB images, there are also a few other changes we’re making which I believe will help with your particular case.

There is a fair chance we’ll be able to submit this update to Apple early next week, so it isn’t too far off.

Also, one way to workaround this for now (if it makes sense for how you use the Apple TV) would be to leave the Infuse app open. AFAIK, tvOS will not clear data from an app which is being actively used.

For now I have removed 15,000 TV Episodes to see if that reduces the DB size sufficiently – however, whatever you’ve got in mind as a fix Im sure I don’t need to point out that unless you are able to reduce the overhead (size) of the current Graphics download by some 50% then nothing is going to help. Whether you can add in an option to completely disable the new characters info (if its that that is causing the issue) then that may be another way. If the problem is an increase in the size of the graphics compared to the ones that thetvdb were compiling then you’ve got a problem. Im sure you don’t want to start telling people for the first time that Infuse now has a library size limitation or that we have to spend a load of money and replace all or 32gb devices with 64gb ones ??? – As your user base grows more and more and the price of servers and disks come down the people are going to grow their libraries ……… what exactly are your thoughts around a fix – Im sure that the several logs I sent you have enabled you to see exactly where the proble is coming from ???

Simon.

I am having the exact same issue and the Infuse app was open (but not in use) at the times the metadata was cleared in both instances. Note I do not use Plex and solely use Infuse on my 32GB AppleTV 4K.

It is fetching for the third time now. 80,000+ tv episodes and 3,000+ movies in my library.

Metadata for only 1,200 files downloaded so far so metadata is only at 30MB so far without any artwork. Diagnostic 4T65B. I’ll try to send another in the morning.

Between this and the ton of mismatched television items due to the switch form TVDB super frustrating.

This reminds me of a couple/few years ago when my metadata kept being deleted over and over again. I was so happy when that issue was resolved and am very disappointed it is back.

1 Like

Well this is actually the most serious issue that a premature Infuse update (again) has caused and it is NOT being treated with the absolute urgency that it requires. Your Infuse is now BROKEN - there is no point in keeping on trying to compile the database - you can ONLY fix it by either getting a 64gb ATV - or by deleting media …… with 85,000 media items it will NEVER work now because the database has grown too big for the ATV. It’s not the metadata that is causing the problem (yours is prob only 400mb) it is the graphics downloads which in your case I am estimating has now grown from circa 12gb up to over 20gb (And you like me have a std 32gb ATV) the switch to this new database - or - the enabling of the character head, and linked media is the issue. James has not yet alluded to what has caused the dB size to DOUBLE in size in this update - and again, unfortunately, represents yet another example of how badly the Infuse so called Beta Testing works ……. So …… basically ANYONE with a LARGE media library now has a nuked infuse that will NEVER work unless the dB size is reduced to an acceptable level. I would also point out that the movie database is nowhere near as comprehensive as the tvdb which is why there are literally tons of TV series either completely missing or mysteriously classified as movies !!! FACT !!!
How do you temp fix it ??? - we’ll I’ve had to remove 15,000 items of media for now and James’s suggestion of keeping Infuse running just doesn’t work because the minute you switch apps - or even just going to settings - will cause the ATV to remove ALL your Infuse metadata that has just taken you 8 hours to compile ……
I have been very restrained in my complaints over this (this time) in order to see how seriously they take this issue - they have had several logs from me in various stages of compile and they have been aware for 3days now …. So let’s see after the weekend - but I’m doubtful that 7.1 can possibly work in this form.

FYI this has been tagged as in-progress.

I VERY aware of that ! Tell me, as a long standing beta tester - why didn’t you notice that the dB had doubled in size ? And just out of interest - how large is YOUR library ? It has been a long standing reported “bug” by me that beta testing is all but impossible if you have a large library as it can take anything from 8 to 18 hours to compile a new library which you HAVE to do every time if you are testing a beta ??? I just seriously wish the programmers would carry out at least ONE test of betas on a large server fed library - it would save an awful lot of aggro and would not result in a release that simply BREAKS infuse like 7.1 has !!!

Mine didn’t double. But even if it did I wouldn’t notice since I have a smaller library and it is under 1GB of metadata.

~2k items

No, only occasionally do beta testers require rebuilding their library.

Maybe they did but everyone’s library will be different and it is impossible to anticipate every possibility.

Well thank you - you have just proved my point on everything :frowning:
You have an “tiny” library that is nowhere near sufficient for any reasonable Beta Testing - as do “most” users that are Beta Testing - being a beta tester is not an honour it about understanding what you are supposed to do and look for as a beta tester. Furthermore unless the code has changed drastically (which is hasn’t) you will find that you dB does compile on every Beta as it is not installed as an update it is installed a new App - and because your library is so small you probably wouldn’t notice it happening but take my word for it - it does occur.
As far as your DB is concerned your DB HAS nearly doubled in size - it’s impossible for it not to have - you just didn’t notice it. A Media item before 7.1 took up approx 180/250kb - in 7.1 it takes up approx 360kb.
And unfortunately no - the programmers do not - nor have they ever tested on a medium to large library - if they had, they would have seen this present issue immediately and historically they would have spotted numerous other things in the past that people like myself end out screaming about ! I have LONG suggested to James that it would really help everyone if they just invested in a media server with a LARGE library for testing.
Virtually EVERY issue that has caused weeks of grief since V4 has been caused by ineffective Beta testing and worse, dreadful primary bench testing and the absence of any testing on large libraries.

1 Like

Yes I realize it has to be the artwork. I haven’t been an User back to v4, but I definitely remember having this issue back with the update to around v5.6 in April 2018 and it took a few weeks until it was fixed by v5.7.1 and then had some issues. It happened a couple of other times in late 2018 if I remember correctly, but it has been fairly smooth sailing since until this update…

As an update, I have left infuse open without switching apps and it finished it’s third download of metadata and images. The total size of my metadata is 17.8 GB.

I have attempted to submit a new diagnostic, however I simply get a “Upload failed” error with the only option being to close.

My library consists of 3,600+ movies, nearly 81,000 tv episodes and almost 800 items classified as other for a total of jus over 85,000 items.

I am assuming that as soon as I switch apps, the AppleTV will clear everything again so I am going to try to leave open for the moment. It’s unfortunate that the metadata is so high that apparently the AppleTV won’t even let me submit a diagnostic.

No it won’t / but don’t worry about it - I’ve sent James at least 3 of them at various stages of compile - and he also has the one from my completed compile on the 64gb box - so they DO KNOW EXACTLY what they have done wrong …… but how they fix it is a whole different issue …. It’s simply the size of the dB which as you say is now some 18gb - as opposed to the 8/9gb it was before - a32gb ATV will not take a dB of anything over (guess) 12gb before wiping itself. It’s completely unacceptable that updates are not tested on a reasonably sized media server like 25% of infuse users have.
BTW - why have you got 800 items unknown ???
Out of some 50,000 items I’ve only got 30 unknown - and that’s cos they are family old home movies ?

I left for a while and attempted to submit again, this time it went through. NNJ8K

About 200 before the switch from TVDB which are mostly home movies and other various things that I just find by folder and file name when needed.

A question that you should have been asked but haven’t ……

What is the breakdown of your item numbers of movies/tv progs ?

Before the 7.1 update when was the last time you cleared your dB and did a fresh compile.

It was suggested that the caching of old data was the issue but you and I have proved that NOT to be the case as we have both done several FRESH compiles each where the cache was cleared - so let’s hope that their assumption/misunderstanding of that as the cause is NOT what they are working on as a fix because that will do nothing to help us !

As I’ve mentioned before the issue is most likely 1 of 2 things …… either tmdb downloads more than necessary graphics compared to tvdb - or the graphics from tmdb are substantially larger than those from tvdb …… either one is going to be a big issue for them to fix …. The other possibility is that the enabling of the character links is causing a doubling up of graphic downloads …. Whatever the issue is - it is really bad that that it wasn’t picked up before release !

Im afraid that whichever way you look at it the TV side of tmdb is still very much in its infancy and is nowhere near as complete as tvdb - there are literally hundreds of TV series that are not listed (or are listed wrongly as movies on tmdb) as well as naming protocols that are wrong or completely illogical - it was definitely far too soon for such a move away from tvdb. I’m going to start another topic on this issue separate from this.

I’m assuming that 7.1.2 doesn’t fix this at all ? You know James it would be a LOT MORE HELPFUL to us all if you could clearly tell us exactly what these interim updates ARE FIXING ……. To say that your descriptions are somewhat vague is an understatement …… in the meantime perhaps you could give us some real feedback on where you are with the dB size issue ???